Jumper T8sg and E010s flysky AFHDS = latency

More
08 Oct 2017 17:18 - 14 Oct 2017 08:42 #64920 by AlbE
Hi everybody

I got a jumper T8gs since 10days, it works great except with my eachine E010s flysky AFHDS

I bind it easy but I have a 1sec latency on each instruction (i try in 2 different E010s => same problem)

Does someone have the same problem ?

Compatibility problem ? T8gs problem ?

Thanks for your help
Last edit: 14 Oct 2017 08:42 by AlbE.

Please Log in or Create an account to join the conversation.

More
08 Oct 2017 18:48 #64921 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
This quadcopter FLYSKY version of the receiver is AFHDS, not AFHDS 2A.

Please Log in or Create an account to join the conversation.

More
08 Oct 2017 19:45 #64924 by AlbE
I know

But the jumper is compatible with the AFHDS, no ?

Please Log in or Create an account to join the conversation.

More
09 Oct 2017 04:04 #64928 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
I don't know, try to ask protocol developer (goebish).

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 10:24 - 12 Oct 2017 10:38 #64979 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
Hi, I'm the developer of the AFHDS 2A protocol, not AFHDS ;)

I've just received a Flysky E010S (thanks Fred !) and there's no problem with my T8SG, no latency, everything works perfectly on my end.
The same machine with Fred's T8SG has the latency issue.

I'm not sure what the problem is and it seems you're not the only one to have this issue.

I'd like to make a test build with configurable packet interval, just to try, vlad_vy, I had a look at your github but I can't find a branch for the T8SG, is it available somewhere, is there a reason it's not available in master branch yet ?
Last edit: 12 Oct 2017 10:38 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 10:44 #64980 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
There is not the decision what to use: devo7-256 with some hardware detection method or separate build for T8SG. I use only local build environment for separate T8SG build.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 10:47 - 12 Oct 2017 10:47 #64981 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
Ok, that's what I thought but I wasn't sure, I'm just coming back from holidays ;)
Would you commit it on your github (new branch) or just send your sources to me for test purpose ?
(myname @gmail.com)
Last edit: 12 Oct 2017 10:47 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 11:00 #64982 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
Check your mail.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 11:05 - 12 Oct 2017 11:05 #64983 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
Thanks very much vlad_vy !

Oh, I've just tried with my 2nd T8SG (the first model, with unattainable USB connector :P) and it exhibits the same issue, loss of packets (blue led blinks on the E010S) and extreme latency that makes it uncontrollable.

I've to check if I've the same issue with other A7105 protocols (Hubsan, AFHDS 2A) or if only the AFHDS protocol is affected.
Last edit: 12 Oct 2017 11:05 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 11:08 #64984 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
My Hubsan H107C works fine.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 11:12 - 12 Oct 2017 11:14 #64985 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
Probably it depend from TXID.
Last edit: 12 Oct 2017 11:14 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 11:22 - 12 Oct 2017 11:23 #64986 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
No, I've tried a few different IDs on both radio, one works (the "dev" edition) while the other one exhibits the latency issue.
I've also tried to lower TX power, no change.
Last edit: 12 Oct 2017 11:23 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 12:57 - 12 Oct 2017 18:12 #64988 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
I tried tweaking packet interval (it was changed ~1 year ago to match new AFHDS transmitters, see here ) but that doesn't change anything :(

Hubsan protocol (A7105 as well) works without any issue but this protocol does not have any frequency hopping, so I suppose it's more resilient to packet loss.

I'll try AFHDS 2A ...
Last edit: 12 Oct 2017 18:12 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 13:46 - 12 Oct 2017 17:32 #64989 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
Anyway, I can confirm that it doesn't depend from TXID, I've set the same txid in hardware.ini in both TXs, same fixed ID (both transmitters can connect to the Rx without rebind) and there's still the same issue.
I've also tried with a Devo 10 and a Turnigy i10, no problem ... Could it be an hardware issue with rev1 T8SG (the one with misplaced USB connector) ? That's surprising because I don't think they're using different 4-in-1 modules.
Last edit: 12 Oct 2017 17:32 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 13:52 #64990 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
Well, I suppose it's time to grab the HackRF to understand what's happening :)

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 14:07 #64991 by fredbotton
Replied by fredbotton on topic Jumper T8sg and E010s flysky AFHDS = latency
I have tried several Flysky and Flysky AFHDS 2A devices with first batch T8SG (hiddenUSB), most fail binding, drop connection and/or experience latency. Looks like the the A7105 is not on that model for some reason...

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 15:38 - 14 Oct 2017 12:30 #64994 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
All I can see with SDR is that the working T8SG and the Devo 10 has an almost perfect gfsk center frequency (only +30kHz drift, and it could be my HackRF that's not calibrated ...):

(working T8SG and Devo 10 captures are ~similar)

while the non working T8SG has a +80 kHz drift compared to the working ones (110 kHz in total):


Both signals look pretty similar, only shifted in the frequency axis.

That's probably due to the (non) accuracy of the crystal oscillator they're using for the A7105.
I'm not sure this can be an issue, I think the RX side should have enough selectivity to cope with that, but maybe it's on the edge and most packets are not received ...

edit: I've also tried to swap antennas, but same result.
Last edit: 14 Oct 2017 12:30 by goebish.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 15:40 #64995 by vlad_vy
Replied by vlad_vy on topic Jumper T8sg and E010s flysky AFHDS = latency
Telemetry ON or OFF? Does AFSDH support telemetry?

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 15:41 #64996 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
No, there's no telemetry in AFHDS, that's a 1 way protocol, even for bind.

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 17:06 - 13 Oct 2017 21:22 #64999 by goebish
Replied by goebish on topic Jumper T8sg and E010s flysky AFHDS = latency
The A7105 has a frequency compensation function, but only in Rx mode (see chapter 14.3 in A7105 datasheet), unlike the cc2500 & cyrf6936 there's no way to fine tune the frequency in software on Tx side :(

... I've an old 4-in-1 module, I've never installed it in my Devo 10 because it's the first version with non working LNA on nrf24 & a7105, I think I'll try to swap it with the one in the non (well, almost) working T8SG to check if that's the problem.

... let's grab the hot air rework station now.

edit: A7105 Tx frequency can be fine tuned with registers 0x11, 0x12 & 0x13, the nrf24l01 is the only radio on which we can't fine tune Tx frequency.
Last edit: 13 Oct 2017 21:22 by goebish.

Please Log in or Create an account to join the conversation.

Time to create page: 0.303 seconds
Powered by Kunena Forum