New help with 4in1 on Devo 7E

More
17 May 2018 15:38 #69279 by DPyro
New help with 4in1 on Devo 7E was created by DPyro
I have installed the 4in1 as per instructions but when it boots up it says missing modules cyrf6936. I tried binding to a CX-10 but all models seem to have an asterisk in front of them.

Here is my hardware.ini
;Only useful for transmitters with an after-market vibration motor
;enable-haptic=1
;
;switch_types: 3x2, 3x1, 2x2
;extra-switches=
;
;button_types: trim-all, trim-(left|right)-(up|down|both)
;May occur more than once if necessary.
;extra-buttons=
;
[modules]
; there is no need to enable the cyrf6936 module unless
; it is wired to an alternate port. It is Enabled automatically otherwise
; enable-cyrf6936 = B12
has_pa-cyrf6936 = 1
;enable-a7105 = A13
;has_pa-a7105 = 1
enable-cc2500 = A14
has_pa-cc2500 = 1
enable-nrf24l01 = A15
has_pa-nrf24l01 = 1
; enable-multimod = A13

Please Log in or Create an account to join the conversation.

More
18 May 2018 11:47 #69294 by DPyro
Replied by DPyro on topic New help with 4in1 on Devo 7E
I'm wondering if it is the pad that got lifted when removing the old module is the issue...

Please Log in or Create an account to join the conversation.

More
18 May 2018 17:13 #69301 by DPyro
Replied by DPyro on topic New help with 4in1 on Devo 7E
So I opened up the transmitter and tested continuity and found a stray wire going from red to white was shorting out. Pins from 3-4 in picture above. On boot I get missing modules NRF24101 missing, checking the different models shows some without the asterisk now.

Please Log in or Create an account to join the conversation.

More
18 May 2018 23:14 - 18 May 2018 23:15 #69303 by DPyro
Replied by DPyro on topic New help with 4in1 on Devo 7E
Not entirely sure what to do here. The center two pins on the 4in1 beep with the continuity checker, I think the top is ground and bottom is not used so I don't know if that's even an issue. Also made sure none of the other joints were shorting out. I think only the NRF24101 is not working which sucks as it's the main one I need working. I followed this guide.
Last edit: 18 May 2018 23:15 by DPyro.

Please Log in or Create an account to join the conversation.

More
20 May 2018 15:55 - 20 May 2018 15:55 #69338 by DPyro
Replied by DPyro on topic New help with 4in1 on Devo 7E
An update since no one was able to help me. Two center pins on 4in1 are both ground so it makes sense they connect. I swapped wires soldered to CSN2401 and CSN7105 and my changes reflect that in the hardware.ini. Also after a lot of trial and error I was able to solder the 2nd pin on the STM32F103.

Here are my changes in the hardware.ini
;Only useful for transmitters with an after-market vibration motor
;enable-haptic=1
;
;switch_types: 3x2, 3x1, 2x2
;extra-switches=
;
;button_types: trim-all, trim-(left|right)-(up|down|both)
;May occur more than once if necessary.
;extra-buttons=
;
[modules]
; there is no need to enable the cyrf6936 module unless
; it is wired to an alternate port. It is Enabled automatically otherwise
; enable-cyrf6936 = B12
has_pa-cyrf6936 = 1
enable-a7105 = A15
has_pa-a7105 = 1
enable-cc2500 = A14
has_pa-cc2500 = 1
enable-nrf24l01 = A13
has_pa-nrf24l01 = 1
; enable-multimod = A13
Last edit: 20 May 2018 15:55 by DPyro.

Please Log in or Create an account to join the conversation.

Time to create page: 0.269 seconds
Powered by Kunena Forum