×
Important information

To file a bug, find instructions here: Reporting bugs

Please only post images or files to this forum which you either own the copyright to or you are sure can be distributed under an open source license.

Problems binding with Lemon Rx LM0052 with DSMX

More
04 Jun 2018 16:25 #69533 by jim_s
I have recently purchased a Lemon Rx LM0052 receiver. This has a built-in altimeter, and sends altitude and vario telemetry, along with the more standard values such as battery voltage, etc. I'm trying to bind it to my Devo 10, running Deviation v5.0.0.

I have been unable to successfully bind to the LM0052 via the DSMX protocol. I go through the proscribed binding procedure (bind plug in place, power on Rx, rapid red flashing Rx LED, power on Tx, hit bind in the Deviation Model menu, at which point the Rx LED should then flash slowly, then go solid to indicate successful bind) - instead, however, the rapid flashing LED stops flashing for a moment, then returns to rapid flashing, with occasional slightly-longer flashes accompanied by some glitching noises in the servos. I have some manner of control of the servos via the Tx, in that they respond to stick movement, but instead of moving smoothly, they move in a stuttering/jerky manner - nothing one would ever want to fly with. I've tried the binding procedure numerous times, with different batteries, different distances between the Tx and Rx, with and without servos attached - all with the exact same end result - continued rapid flashing with occasional (seemingly random) longer flashes accompanied by servo glitching noises, and the jerky movement of the servos.

I can bind just fine to the LM0052 via DSM2 - everything binds as expected, servos move smoothly, I get all the telemetry data, etc. I can bind to my OrangeRx R620X and R410X via DSMX receivers without any problem, and can receive telemetry from the R620X using DSMX.

So, I don't know if this is perhaps some incompatibility between the Lemon Rx implementation of DSMX (they are officially calling it "DSMP") and the Deviation implementation of DSMX, or what. DSM2 is fine for my purposes (I flow solo, in wide-open fields away from sources of external RF), but it would be nice to be able to get the DSMX protocol working with the LM0052 - I suspect that with its mix of low price and high functionality, it will prove to be a very popular Rx option.

Another item of note is that when binding to the OrangeRx R620X via DSMX, I cannot bind if I have the Telemetry option turned on in the Model Protocol spin box - I have to bind with Telemetry off, then enable Telemetry in the Tx, and all is well - I mention this, as it might possibly be an indication of some underlying problem with the Deviation DSMX binding process? (Or, maybe this is the way its supposed to work, and I'm just unaware of that?)

I can post this in the Development forum, if appropriate, but this seemed like maybe the better starting point.

Thoughts or ideas? I'm willing to try some different binding approaches, if it helps diagnose what might be going on - just let me know. (FWIW, I've also tried binding via DSM2, then switching the protocol to DSMX at the Tx end, but that failed outright - no communication between the Tx and Rx, at least not that I can discern.)

Please Log in or Create an account to join the conversation.

More
04 Jun 2018 16:44 #69536 by vlad_vy
Try bind with 8 channels mode. Many 7ch receivers actually are 8 channels capable, but with 7 output channels. Also, try bind with increased distance, 2 meters or more.
Binding Problems
It is not unusual to encounter difficulties binding DSM-type receivers, with the receiver either continuing to flash rapidly or starting the bind process but never attaining the solid light that indicates a link. Being very sensitive, the Lemon RX Telemetry Receiver may be a little fussier than usual about bind conditions.
Bind problems can usually be overcome by simply increasing the distance between transmitter and receiver during bind. Even then, more than one try may be needed to achieve success. For each try, repeat the entire sequence, starting with both receiver and transmitter powered down.
If binding fails at 2 meters, start again, moving further away before turning on the transmitter in bind mode, and have your body between the transmitter and receiver to attenuate the signal further. When binding, stay away from metallic objects (such as cars, wire fences and steel tables), as well as damp ground and other conductive surfaces. Wireless routers and other WiFi sources can also inhibit binding.

Please Log in or Create an account to join the conversation.

More
04 Jun 2018 16:56 - 04 Jun 2018 16:59 #69537 by jim_s
Cool, thanks for the tip on 8ch - I'll try that tonight.

As regards the Lemon Rx docs on "Binding Problems" (which you quoted), I tried all variety of distances, 'body shielding', removing the Tx and Rx from wifi environments, indoors, outdoors - I bet I've easily tried 50 different combinations, all to no avail. I think any environmental contributions to the problem have been pretty well laid to rest in my case. :-) (A big take-away for me on this, is that you can get binding interaction between the Tx and Rx at shockingly large distances!!)
Last edit: 04 Jun 2018 16:59 by jim_s.

Please Log in or Create an account to join the conversation.

More
04 Jun 2018 17:07 #69538 by vlad_vy
Also, try to use "OrangeRx" protocol option. The option can help with bind problems and high frame loss rate for all third party receivers.

Please Log in or Create an account to join the conversation.

More
05 Jun 2018 05:21 #69552 by jim_s
Ok, so tried the 8ch idea, but ended up with the same result - quasi-bound, but still rapid flashing bind mode light, and jerky movement of the servos.

I can see the "OrangeRx" option under the DSMX protocol spinbox on the emulator, but it doesn't show up on my Tx. In fact, the only option that shows up under the DSMX protocol spinbox is the Telemetry (On/Off options) item. I'm guessing maybe the emulator I'm running is a more current version than the version I have on my Devo10? (I loaded the version on my Devo10 about a month or so ago.)

Does this seem plausible, or am I somehow missing something on the Tx?

Please Log in or Create an account to join the conversation.

More
05 Jun 2018 05:41 #69553 by vlad_vy
Probably you use v5.0.0 release. Try to flash latest nightly build.

Please Log in or Create an account to join the conversation.

Time to create page: 0.230 seconds
Powered by Kunena Forum