New T8SG V2 Plus incompatible w/ recent firmware

More
23 Jan 2019 00:09 - 23 Jan 2019 00:10 #72481 by Tonsuke
I bought T8SG V2 Plus yesterday and failed to update its firmware. It seems memory / storage of V2 Plus has been destroyed by updating firmware. My friend who already had V2 plus bought another one recently and having same problem only with new one. He found there's a difference between new and old hardware that a chip on board which assumed as memory chip. This is my guess but Jumper changed the hardware of memory chip and also change the way of handling memory in their recent firmware which is incompatible with current nightly builds. Will it able to be fixed near future ?

BTW, destroyed file system can be fixed with backup files and DFU but little tricky in order to make it recognizable by Windows.
Last edit: 23 Jan 2019 00:10 by Tonsuke.

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 06:03 - 24 Jan 2019 07:53 #72485 by vlad_vy
Can you try modded nightly build T8SG V2 Plus firmware with flash memory auto detection?

File deleted, now see nightly builds...
Last edit: 24 Jan 2019 07:53 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 08:04 #72487 by Tonsuke
I tried and find it is working !! I may need to confirm some other functions but am feeling it's fixed ! Thank you soooooooooooooo much ! Will this mod be implemented future nightly build ?

Thanks millions again.

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 08:28 #72490 by vlad_vy

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 08:44 #72491 by Tonsuke
Great ! Thanks again.

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 10:03 #72494 by lrxsmb
Hello everyone!!!

I had the same issue with a t8sg v2 plus buyed from aliexpress end of december.
Work ok on arrival but weird range issue (but it's an other story...) so decided to flash with the lastest nightly build...
Unfortunately the TX doesn't work after attempt to update...
test many many thing even change the flash chip, but always the same result, tx start on USB mode and memory is not recognised on windows explorer, but seen as RAW on disk management and unable to format it!
Yesterday I see Tonsuke post on facebook T8SG group where he speak of the same problem.
Ask him how he solve it... He said he flash with stock firmware (that I don't have cause don't make a backup...) he send it to me, so flashed it, and after many try I was able to format the memory (FAT 4096 and not fast format) but the memory didn't appear in windows explorer and can't send library into...
I just had to add a path and letter on disk management and AT LEAST!!! it appear on Windows explore!!!
After that I decided to flash with vlad_vy firmware, copy library and boot for the first time in a week!!! :woohoo: :woohoo: :woohoo: :woohoo: :woohoo:
SO.... A big thanks to vlad and Tonsuke for giving me a bit of hope and the solution!!!

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 10:59 #72495 by vlad_vy
Fix accepted, you can use next nightly builds.

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 11:08 #72496 by lrxsmb

vlad_vy wrote: Fix accepted, you can use next nightly builds.

Thanks !
Just briefly test my radio and note that now max power output is 100mw instead of 150mw.
Is your firmware ?

Please Log in or Create an account to join the conversation.

More
23 Jan 2019 11:19 #72497 by vlad_vy

Please Log in or Create an account to join the conversation.

More
26 Jan 2019 00:20 #72530 by Tonsuke
I think both DeviationUpload and Dfuse tool also need to be updated hence it seems the tools handle memory directory. Actually. I can't format file system by DeviationUpload tool properly.

Please Log in or Create an account to join the conversation.

More
17 Jan 2020 14:16 #75742 by Donang
I have the same problem. Can anyone share how to fix it? I'm a Mac user.

Please Log in or Create an account to join the conversation.

More
20 Jan 2020 08:42 #75765 by Quemelias
Replied by Quemelias on topic New T8SG V2 Plus incompatible w/ recent firmware

vlad_vy wrote: Pull request placed
github.com/DeviationTX/deviation/pull/647

Is there a post where you indicate how these types of files are installed?
Thanx

Please Log in or Create an account to join the conversation.

Time to create page: 0.050 seconds
Powered by Kunena Forum