×
Important information

To file a bug, find instructions here: Reporting bugs

Please only post images or files to this forum which you either own the copyright to or you are sure can be distributed under an open source license.

Binding Devo rx601 receiver

More
27 Aug 2018 08:44 #70469 by suzygs1000
Binding Devo rx601 receiver was created by suzygs1000
HI,

I have always used Walkera transmitters and receivers.

I have a large number of RX601's.

I have two Devo 10 tx's, one with Deviation, and one standard.

I recently purchased a Irangex IRM8 transmitter.

I would like to put all my quads on the Irange, as the Devo 10 with Deviation on it now has two broken switches.

A number of the quads have RX601 receivers, and I have found that they will not bind with the Devo protocol on either the DEVO10 with Deviation on , or the IrangeX transmitters.

I have a couple of RX601's that I have cleaned, and both will bind with my DEVO10 standard, so I don't think it is the rx's.

The DEVO Deviation used to bind with RX601's, I am pretty sure ...but that would probably a year or so ago.

Is there something I am missing when trying top bind Deviation with RX601?

thanks Dave.

Please Log in or Create an account to join the conversation.

More
27 Aug 2018 08:59 #70470 by FDR
Replied by FDR on topic Binding Devo rx601 receiver
If you used Fixed ID for the bind (and I hope you did), then you need to clear the Fixed ID from the receivers (with the bind plug), then rebind them to the other transmitter first with auto bind, and after that with a Fixed ID.
In deviation you can write the same txid into the hardware.ini, so you can use either transmitters to control a quad without the need to rebind.

The other option would be to use auto bind all the time, but I suggest not to do so, because Fixed ID helps in case you need to recover the link after restart, brownout, etc...

Please Log in or Create an account to join the conversation.

More
27 Aug 2018 12:50 #70476 by suzygs1000
Replied by suzygs1000 on topic Binding Devo rx601 receiver
Hi, FDR,

Thanks for the reply, but unfortunately, that didn't work either.

I cleared the rx, bound it to the Devention DEVO10 , set up fixed id (550934), disconnected the rx from the Devo10, reconnected to make sure it was good, and it reconnected immediately.

I then went into the model on the IrangeX, entered the same fixed id (550934), and tried to bind, but no success.

I then tried the same procedure with the DEVO10 with Deviation, and again no success.

Looks like I may have to continue using the DEVO10 with Walkera software to fly my Devo receiver models.

I do have a 7 channel rx which I got with one of the transmitters. I have not tried to bind that with Deviation yet.

I will see if I can find that one, and see if it will bind, and advise further.

Again, I am pretty sure that I used to be able to bind my old DEVO10 with Deviation on it to the rx601 receivers, but I could be mistaken.

thanks again for your help
Dave.

Please Log in or Create an account to join the conversation.

More
27 Aug 2018 14:09 #70477 by FDR
Replied by FDR on topic Binding Devo rx601 receiver
No, it isn't enough to have the same Fixed ID!
Each TX has it's unique TXID, which is included in the bind together with the Fixed ID.

However you can let two (or more) deviation transmitters to have the same TXID throw writing a txid entry with the same value into the hardware.ini of each transmitter.
Then you can bind once and use the same RX with either transmitter, but you don't have this feature on the stock Walkera devention fw...

Please Log in or Create an account to join the conversation.

More
27 Aug 2018 21:21 #70482 by suzygs1000
Replied by suzygs1000 on topic Binding Devo rx601 receiver
Ok, thanks , but it still means that I am unable to bind my Walkera RX601's to Deviation.

Sometimes, Autobind will work, but is very inconsistent, and changing to fixed id after bind doesn't work. It will not bind again.

Is there anyone who is successfully binding rx601 with Devention?

thanks again for your interest, FDR

regards Dave.

Please Log in or Create an account to join the conversation.

More
27 Aug 2018 22:18 #70483 by Schugy
Replied by Schugy on topic Binding Devo rx601 receiver
I only own 2 Rx601 and both ( 1 | 2 ) work with my Devo 8S running Deviation 5.0.0 release firmware. Both work with fixed ID set. If you can´t connect to the receiver after setting the ID just delete it and try again. I also own several Rx802, Rx-SBUS, a Rx702, a Rx701 and Rx1002 and they all work with my Devo 8S and F7. On my Devo F7 I use a nightly build (29th of Nov. 2017 deviation-devof7-v5.0.0-e50fce3). I don´t have any experience with later Deviation builds.
Have you tried several transmit power settings, setting 6 channels or disabling telemetry in the devo protocol options? At least the Devo 10 should work. Long time ago some multiprotocol RF modules (3in1 or 4in1) had problems with one of their chips and therefore the dependent protocols. Maybe you can find something.

Please Log in or Create an account to join the conversation.

More
01 Oct 2018 13:23 #71124 by suzygs1000
Replied by suzygs1000 on topic Binding Devo rx601 receiver
Thanks, Schugy .... still no real success ...

I thought it may have been a firmware problem so tried to update to later firmware ... big mistake ... after upgrade, screen was blank at turn on, and power switch was not working. I reflashed it to the original fw and started playing around again.

Using your method, I can bind the rx601 to the Irangex, but if I go and update fixed ID while it is still bound, then turn them both off, it will not rebind.

The problem is that the Irangex is not updating the rx601 with the fixed id, so obviously will not rebind.

I have verified this, as the rx601 will still rebind with my devo10 tx while fixed id is off,

well, back to the drawing board ....thanks again Dave.

Please Log in or Create an account to join the conversation.

Time to create page: 0.283 seconds
Powered by Kunena Forum