12s more bugs (solved)

More
02 Mar 2019 23:19 - 04 Mar 2019 01:23 #73130 by Birdman
12s more bugs (solved) was created by Birdman
vlads last build with latest protocols.

Adding or removing model icons resets "all" transmitter configuration settings to defaults requiring touch screen and stick recalibration.

Includes all battery and alarm settings.
Last edit: 04 Mar 2019 01:23 by Birdman.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 09:52 #73138 by vlad_vy
Replied by vlad_vy on topic 12s more bugs (solved)
I can't reproduce it with Devo8 and Devo12-XMS. Can you provide description step by step?

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:16 #73140 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
12s touch screen and sticks calibrated.
Batt voltage alarm set.
All transmitter configurations set to my preferences.

Plug tx into pc.
Press and hold ent while powering on to enter usb mode.
Open modelico folder.
Copy and paste model icons. Same ones used on 8s
Turn off tx and unplug cable.

Turn on tx.
All transmitter configuration settings are back to factory defaults.
Touch screen, sticks need calibrating again.
All settings including batt voltage alarm etc have returned to factory defaults.

Just tried it again, same result. There is a bug.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:19 - 03 Mar 2019 10:22 #73141 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
Have done this many many times on 8s never a problem, every time I setup a new model. Make 96x96 bmp of picture using gimp.

Pictures work on 12s.

Problem is all transmitter config settings return to defaults when I add or remove model icons. 12s must then be recalicrated.
Last edit: 03 Mar 2019 10:22 by Birdman.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:33 - 03 Mar 2019 10:35 #73142 by vlad_vy
Replied by vlad_vy on topic 12s more bugs (solved)
Anyway I can't reproduce it. I can delete and add icons to Devo12-XMS without problems.

Probably you have a problem with devo12 filesystem. Try format USB drive and write filesystem from firmware archive. Use Safely remove hardware after write.
Last edit: 03 Mar 2019 10:35 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:35 #73143 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
I just tested something.

It appears it has nothing to do with modelico, same problem/thing happens when I only enter usb mode.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:36 #73144 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
Bug

Thanks anyway.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:40 #73145 by vlad_vy
Replied by vlad_vy on topic 12s more bugs (solved)
devo8 and devo12 use the same code, devo12 code is different with handling "media" folder only.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:48 #73146 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
I have 2018-07-31 code in 8s

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 10:51 - 03 Mar 2019 10:53 #73147 by vlad_vy
Replied by vlad_vy on topic 12s more bugs (solved)
I have 2019-03-01 code in 8s, 12s, f12e, t8sg, t8sg_v2_plus.
Last edit: 03 Mar 2019 10:53 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
03 Mar 2019 11:11 #73148 by Birdman
Replied by Birdman on topic 12s more bugs (solved)

vlad_vy wrote: Anyway I can't reproduce it. I can delete and add icons to Devo12-XMS without problems.

Probably you have a problem with devo12 filesystem. Try format USB drive and write filesystem from firmware archive. Use Safely remove hardware after write.


Ok. Will try formatting again. Maybe I forgot to safely remove hardware.

Will report back soon.

Thanks

Please Log in or Create an account to join the conversation.

More
04 Mar 2019 01:22 #73169 by Birdman
Replied by Birdman on topic 12s more bugs (solved)
Yes, after some searching and reading it appears the 12/12s does not like it if you do not safely remove hardware. Many others have reported similar issues.

Please Log in or Create an account to join the conversation.

Time to create page: 0.245 seconds
Powered by Kunena Forum