Devo 12s 3in1 / 4in1 RF module neat installation.

More
22 Nov 2016 16:55 #56171 by HappyHarry
Replied by HappyHarry on topic 3in1 / 4in1 RF module

victzh wrote: As nobody's using 'Freq coarse', and frankly it's not coarser than fine, I plan to remove it. Do you think that one 'Freq tune' option is enough?


apart from vmsda's problems all reports i've seen about the 3/4in1 s-fhss crystal freq issues have been solved using freq fine, so imo i think that it would be ok to remove freq coarse.


vmsda have you checked that your modules cc2500 chip is functioning ok by using another model/receiver than the xk100, or even anything frsky based? or have you confirmed that your xk100 is functioning properly with the stock tx or another s-fhss tx? as i had no issues with my 4in1 u7e binding to my xk100, iirc my freq fine ended up centering around +45

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 17:30 #56172 by hexfet
Replied by hexfet on topic 3in1 / 4in1 RF module

victzh wrote: As nobody's using 'Freq coarse', and frankly it's not coarser than fine, I plan to remove it. Do you think that one 'Freq tune' option is enough?

I agree with this change. One option is just fine ;)

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 18:23 #56176 by vmsda
Replied by vmsda on topic 3in1 / 4in1 RF module

C0ckpitvue 777 wrote: Use the Frsky protocol.

I have done both set of procedures (freq-thin, freq-coarse) with Frsky (just removed telemetry because it is not supported in the 7E), and unfortunately the bind lights never showed up. In desperation, also had a peek at errors.txt in the 7E files, but it was empty. Thank you again for your help.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 19:18 #56178 by vmsda
Replied by vmsda on topic 3in1 / 4in1 RF module

HappyHarry wrote:

victzh wrote: As nobody's using 'Freq coarse', and frankly it's not coarser than fine, I plan to remove it. Do you think that one 'Freq tune' option is enough?


apart from vmsda's problems all reports i've seen about the 3/4in1 s-fhss crystal freq issues have been solved using freq fine, so imo i think that it would be ok to remove freq coarse.


vmsda have you checked that your modules cc2500 chip is functioning ok by using another model/receiver than the xk100, or even anything frsky based? or have you confirmed that your xk100 is functioning properly with the stock tx or another s-fhss tx? as i had no issues with my 4in1 u7e binding to my xk100, iirc my freq fine ended up centering around +45

My XK-X1OO works fine with the stock S-FHSS transmitter, an Align T6 (=Futaba 6J): the Bind is instantaneous.
I have 3 other S-FHSS machines, they are helis. I tried to bind one of them, an XK-K100 (not to be confused with the above, which is a quad), and could not get a Bind with this one either. Other than that, I have a DSMX heli which binds fine, but of course does not use the same module, right?

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 19:25 #56179 by Arnold
Replied by Arnold on topic 3in1 / 4in1 RF module

NotFastEnuf wrote: I've had my devo 8 a long time. Long enough to remember putting in the 8s module so that I could get telemetry. Does the new 4 in 1 module have all the same telemetry functionality that our origional modules have?


I didn't see a response to this question & I'm curious about it too. Anybody know?

Too many hobbies & too many Devos!
Who knows where the time goes?

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 20:01 #56181 by victzh
Replied by victzh on topic 3in1 / 4in1 RF module
Telemetry - yes, it should have to have it. As far as I understand, the difference between 8 and 8s module is using LNA for receive part to enhance sensitivity. Newer 4-in-1 (that is being sold now) has the receive path properly wired for all 4 modules.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 21:15 - 22 Nov 2016 21:16 #56185 by HappyHarry
Replied by HappyHarry on topic 3in1 / 4in1 RF module

vmsda wrote: My XK-X1OO works fine with the stock S-FHSS transmitter, an Align T6 (=Futaba 6J): the Bind is instantaneous.
I have 3 other S-FHSS machines, they are helis. I tried to bind one of them, an XK-K100 (not to be confused with the above, which is a quad), and could not get a Bind with this one either. Other than that, I have a DSMX heli which binds fine, but of course does not use the same module, right?


i'm at a loss then bud, except maybe to suggest trying an older deviation build incase something added recently has affected the s-fhss/7e? perhaps try victzh's early s-fhss build here >> www.deviationtx.com/downloads-new/catego...-s-fhss-freq-options also for binding i power on the quad and wait for all 4 leds to go solid, then i hold the bind button on the quad till only the red led's are on, then i bind with the tx. is this the method you are trying?
Last edit: 22 Nov 2016 21:16 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 21:27 #56186 by vmsda
Replied by vmsda on topic 3in1 / 4in1 RF module

HappyHarry wrote:

vmsda wrote: My XK-X1OO works fine with the stock S-FHSS transmitter, an Align T6 (=Futaba 6J): the Bind is instantaneous.
I have 3 other S-FHSS machines, they are helis. I tried to bind one of them, an XK-K100 (not to be confused with the above, which is a quad), and could not get a Bind with this one either. Other than that, I have a DSMX heli which binds fine, but of course does not use the same module, right?


i'm at a loss then bud, except maybe to suggest trying an older deviation build incase something added recently has affected the s-fhss/7e? perhaps try victzh's early s-fhss build here >> www.deviationtx.com/downloads-new/catego...-s-fhss-freq-options also for binding i power on the quad and wait for all 4 leds to go solid, then i hold the bind button on the quad till only the red led's are on, then i bind with the tx. is this the method you are trying?

No, the method I have been using was suggested by COckpitvue777: power on the 7E, and then power on the X100 holding the Bind button down so bind lights (blue) do not come on.
I can of course try your suggestion, but please confirm at what stage you power on the 7E.
Also, will have a look at victzh's build that you mention.
Thanks a ton.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 22:02 #56188 by victzh
Replied by victzh on topic 3in1 / 4in1 RF module
I don't know about X100 - I don't have it, but XK K-110 binds with recent builds OK.

Do you have any other models based not on S-FHSS, but another CC2500 protocol - FrSky? I'd like to make sure your CC2500 module works.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 22:41 #56189 by vmsda
Replied by vmsda on topic 3in1 / 4in1 RF module

victzh wrote: I don't know about X100 - I don't have it, but XK K-110 binds with recent builds OK.

Do you have any other models based not on S-FHSS, but another CC2500 protocol - FrSky? I'd like to make sure your CC2500 module works.

Can you give me an idea of the frequency at which the XK-K11O binds (to try and save time)?

No, I do not have other stuff. I bought this unit from DaveyP with the Taobao 4in1 already installed, and since he is following this topic perhaps he can shed a light on whether he tested any FrSky stuff.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 22:50 #56191 by victzh
Replied by victzh on topic 3in1 / 4in1 RF module
No I can't, and nobody can. It's not a specific frequency for XK-K110 (I did not touch freq settings at all), or for X100, or any other module. The point is, CC2500 is more sensitive to crystal quality, and as cheap manufacturers source their crystals based on price, not quality, they can deviate from nominal frequency too much. It's usually is not a problem for the manufacturer as they use crystals from the same batch (thus, same deviation) both for TX and RX. It's a problem, though, for us when we try to use our TX with crystal sourced from different vendor. Even if this crystal is ideal and match the specification, the one in the model can be too far from the nominal frequency to bind. For this we have frequency tuning.

Your problem may be in several areas - defective RF module, incorrect hardware.ini description for CC2500 etc. You should ask your seller did he try to use the TX with ANY CC2500 based protocol - S_FHSS or FrSky. The chance is he didn't, all other RF chips worked for him but he was not able to test CC2500 because he does not have such a model.

Please Log in or Create an account to join the conversation.

More
22 Nov 2016 23:28 #56194 by Arnold
Replied by Arnold on topic 3in1 / 4in1 RF module

victzh wrote: Telemetry - yes, it should have to have it...


Thanks, Victzh.
Can you tell us anything about progress on your 4-in-1 project? I'm anxious.

Too many hobbies & too many Devos!
Who knows where the time goes?

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 04:49 #56204 by dc59
Replied by dc59 on topic 3in1 / 4in1 RF module
I have tried to bind my K120 with different CC2500 modules (3in1/4in1 and single CC2500 module), I can't use same frequency setting with all cc2500 module, I think you need to try different frequency setting by yourself.

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 06:56 #56206 by victzh
Replied by victzh on topic 3in1 / 4in1 RF module
Not bad, actually. I've already at 4th revision of the board, and finally decided on the headers - it will use Devo 10 header only and I developed a combined adapter for Devo 7E and Radiolink AT9.

The most important - I almost have the firmware support done. I'm struggling with some platforms yet, but it already works in Devo 10, Devo 7E, and Radiolink AT9.

I will post photos tomorrow.

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 07:04 #56207 by dc59
Replied by dc59 on topic 3in1 / 4in1 RF module

victzh wrote: Not bad, actually. I've already at 4th revision of the board, and finally decided on the headers - it will use Devo 10 header only and I developed a combined adapter for Devo 7E and Radiolink AT9.

The most important - I almost have the firmware support done. I'm struggling with some platforms yet, but it already works in Devo 10, Devo 7E, and Radiolink AT9.

I will post photos tomorrow.


Hi Vic,

Wow, it's really a good news!

If it use Devo10 header,I think it also compatible Devo 8 without adapter, am I roight?

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 07:56 #56208 by victzh
Replied by victzh on topic 3in1 / 4in1 RF module
Yes, but I don't have Devo 8 and can't check it myself. I probably need one more hardware iteration - some footprints are hard to solder the chip to, and I'd move 3.3v pin from IRQ (newer Devos have it marked, but probably unconnected and unused) to another free pin. But it works as it is well enough, just more of support code needed. And for Radiolink still many things need to be fixed, but Devos first.

Trying to debug F4 now.

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 08:33 #56209 by blackmoon
Replied by blackmoon on topic 3in1 / 4in1 RF module
I've been out for a while...

I've bought a 3-1 board some time ago and want to install it in a 7E for a friend.

I read there was an issue with the 3-1 board, does this affects range or just telemetry ?


@ victzh what's the difference between your board and the 4-1 for devo sold at Banggood ?


Thank guys :D

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 14:04 #56214 by HappyHarry
Replied by HappyHarry on topic 3in1 / 4in1 RF module

vmsda wrote: No, the method I have been using was suggested by COckpitvue777: power on the 7E, and then power on the X100 holding the Bind button down so bind lights (blue) do not come on.
I can of course try your suggestion, but please confirm at what stage you power on the 7E.
Also, will have a look at victzh's build that you mention.
Thanks a ton.


I turn the tx on after I set the quad into bind mode, though this is only for the initial bind.

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 15:22 - 23 Nov 2016 15:26 #56216 by dat
Replied by dat on topic 3in1 / 4in1 RF module
my devo12S + 3in1 board bought from local shop , bind with my xk k120 & xk x100-> [ freq coarse +25 , freq fine 0 ] no problem
so , don't delete freq coarse option keep it stay , in update deviation ver , please !
Last edit: 23 Nov 2016 15:26 by dat.

Please Log in or Create an account to join the conversation.

More
23 Nov 2016 15:45 - 23 Nov 2016 15:59 #56217 by dat
Replied by dat on topic 3in1 / 4in1 RF module
try only tune freq coarse math , 5 up slowly plus one time , and enter bind func and wait few second ,
if not bind sucese , keep going 5 up and do it enter again
i have same sim issuse like you , keep trying going and on and on many times , finally bind with xk rx
my devo12s + 3in1 board bind with xk k120 & x100 all done like the way.
sometime when you feel tired and wanna giveup, use your hand little move your plane rx board,
you will found you already bind with it .that's my experence
i tune 1mW tx power and close the xk rx as i can , almost touch the plane board distance , that's my way
Last edit: 23 Nov 2016 15:59 by dat.

Please Log in or Create an account to join the conversation.

Time to create page: 0.198 seconds
Powered by Kunena Forum