Bayangtoys X16 GPS Tx wont power on

More
19 Sep 2018 03:37 - 19 Sep 2018 20:06 #70980 by DroneFisherMan
Bayangtoys X16 GPS Tx wont power on was created by DroneFisherMan
Hi All,

i am using bayangtoys X16 GPS drone.
I managed to solder the antenna on the board, and it was working absolutely fine. Until, I put hot glue on the antenna's solder to make it more solid.

Since then , when I power on the remote the red light comes on for a second and beeps then it goes off. I removed the hot glue and still its doing same thing..

Have I burnt the Tx?

I have checked for any short on the antenna's ground and main wire, there is no short there. I have checked the battery and power, and all looks good.

Could anyone help me out please!


Attachments:
Last edit: 19 Sep 2018 20:06 by DroneFisherMan.

Please Log in or Create an account to join the conversation.

More
19 Sep 2018 06:56 #70982 by FDR
Replied by FDR on topic Bayangtoys X16 GPS Tx wont power on
Be aware, that the hot glue conducts to some extent, so it is not suitable for that.
It might have fried your power amplifier (because of the shortcut), or there still might stayed some residue of the glue.

Please Log in or Create an account to join the conversation.

More
19 Sep 2018 07:16 - 19 Sep 2018 21:03 #70983 by DroneFisherMan
Replied by DroneFisherMan on topic Bayangtoys X16 GPS Tx wont power on
I have removed all glue from it and tested using volt meter on the antenna and sockets around it. There is no short there.

If its the power amplifier then which part is it? Can I replace it?

is it this thing you are referring to? pa

May I know if there is any other troubleshooting I can do to isolate the problem?

the power does come up but then goes away, if I immediately power it off and power back on, then there is no LED,

However, if I pause for 5-10 seconds the intensity of LED is high, and subsequently low if powered on during less intervals.
Last edit: 19 Sep 2018 21:03 by DroneFisherMan.

Please Log in or Create an account to join the conversation.

Time to create page: 0.306 seconds
Powered by Kunena Forum