Hubsan X4 config

More
31 Dec 2012 12:54 #4417 by proteus
Hubsan X4 config was created by proteus
Hello
my X4 config :

2 mode
- 70% dualrate (rudder 60%), 25% expo --> green icon
- 100% dual rate, 0% expo (3D) --< yellow icon

throllte cut : RUD DR --> red icon

2 chrono throttle command

for model icon :
www.deviationtx.com/forum/model-icons/1081-hubsan-x4
i choise second icon rename x4.bmp
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Feb 2013 16:45 #6126 by Rain4LA
Replied by Rain4LA on topic Hubsan X4 config
Hey, thanks for doing the work and posting this. It works great for me.
:)

Please Log in or Create an account to join the conversation.

More
12 Feb 2013 21:05 #6332 by SamtheMan
Replied by SamtheMan on topic Hubsan X4 config
So both you guys modded your radios with that module?

Please Log in or Create an account to join the conversation.

More
13 Feb 2013 16:55 - 13 Feb 2013 16:56 #6363 by proteus
Replied by proteus on topic Hubsan X4 config
Last edit: 13 Feb 2013 16:56 by proteus.

Please Log in or Create an account to join the conversation.

More
13 Feb 2013 17:16 #6366 by Joshua
Replied by Joshua on topic Hubsan X4 config

proteus wrote: with A7105-500m module for me

www.deviationtx.com/forum/how-to/1228-fl...le-with-pics-devo-8s


I use same modul with my Revell QG 550 and it works fine. ;)
www.deviationtx.com/forum/3-feedback-que...upport?start=20#6027

Please Log in or Create an account to join the conversation.

More
06 Apr 2013 09:58 #8619 by proteus
Replied by proteus on topic Hubsan X4 config
modification config for deviationTX 3.0.0 and perso toggle.bmp

for toggle.bmp : www.deviationtx.com/forum/custom-skins/1...tion-icon-toggle-bmp
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Jul 2013 06:04 #12004 by HeliBen
Replied by HeliBen on topic Hubsan X4 config
Anyone have the v2 hubsan x4? just wondering its possible to turn the lights on or off with a switch.

Please Log in or Create an account to join the conversation.

More
10 Jul 2013 03:46 #12158 by jason4207
Replied by jason4207 on topic Hubsan X4 config

HeliBen wrote: Anyone have the v2 hubsan x4? just wondering its possible to turn the lights on or off with a switch.


Just got mine today. I'm also curious on how to get this working.

Please Log in or Create an account to join the conversation.

More
26 Jul 2013 15:49 - 26 Jul 2013 15:56 #12530 by goebish
Replied by goebish on topic Hubsan X4 config
+1

Would be cool to be able to turn off LEDs and most importantly disable auto flip feature while keeping full throws.

I would be glad to help, I've got a hubsan x4 v2 transmitter and a 24MHz logic analyzer but I've no idea of how the A7105 works :blush: (looks like it's not SPI).

Maybe someone can give me some clues so I can tell the devs what are the frames to send ?

Just a guess: has someone tried to enable Ch5 or Ch6 and send different values at them ?
I've not tried by myself because that's my first day on devo10 / deviation (first thing I did was flashing deviation and installing a A7105 module :P) after 4 years with a DX6i, programming deviation is a BIT more difficult, I still have a lot of things to figure out !

Thanks.
Last edit: 26 Jul 2013 15:56 by goebish.

Please Log in or Create an account to join the conversation.

More
26 Jul 2013 16:53 - 26 Jul 2013 16:54 #12533 by sbstnp
Replied by sbstnp on topic Hubsan X4 config
There are no ch5 and ch6 for the Hubsan as of yet, you cannot go above channel 4.

Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire
Last edit: 26 Jul 2013 16:54 by sbstnp.

Please Log in or Create an account to join the conversation.

More
27 Jul 2013 00:44 #12541 by goebish
Replied by goebish on topic Hubsan X4 config
Ok thanks.

I took the plunge and I'm trying to figure out how it works.
Help is welcome :)
www.deviationtx.com/forum/protocol-devel...d-version-on-the-way

Please Log in or Create an account to join the conversation.

More
27 Jul 2013 14:53 #12553 by goebish
Replied by goebish on topic Hubsan X4 config

Please Log in or Create an account to join the conversation.

More
27 Jul 2013 18:36 #12555 by sbstnp
Replied by sbstnp on topic Hubsan X4 config
I should have worder things differently: "there is no user accessible channel over 4 in the current implementation" :)

goebish wrote: Looks like I found the 5th channel :)
www.deviationtx.com/forum/protocol-devel...ion-on-the-way#12552


Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire

Please Log in or Create an account to join the conversation.

More
29 Jul 2013 12:23 - 22 Aug 2013 02:22 #12590 by goebish
Replied by goebish on topic Hubsan X4 config
Attached is a profile for the Hubsan X4 v2 (H107-L):

it requires my patch in deviation for the leds and disable flips functions to work:
bitbucket.org/PhracturedBlue/deviation/p...l-for-hubsan-x4/diff
If you can't build it by yourself and can't wait it is included in the nightly build you might send me a PM and I'll send you the firmware for your TX.
Patch is now included in nightly build.

edit 2013-08-22: proper throttle curve and ail/ele/rud expos.

GEAR 0 -> lights on
GEAR 1 -> lights off

FMODE 0: 75% throws / 60% RUD, -10% expo AIL/ELE, +30% expo RUD
FMODE 1: 90% throws / 70% RUD, -10% expo AIL/ELE, +30% expo RUD flips disabled
FMODE 2: 90% throws / 70% RUD, -10% expo AIL/ELE, +30% expo RUD flips enabled

RUDD D/R 1 -> throttle cut

Attachments:
Last edit: 22 Aug 2013 02:22 by goebish.

Please Log in or Create an account to join the conversation.

More
31 Jul 2013 21:00 - 31 Jul 2013 22:18 #12670 by thibaut47
Replied by thibaut47 on topic Hubsan X4 config
:( hello, i have a DEVO8S + deviationTX naughty build 3.0.0. I had download the model *ini below for my x4 v2 but it doesnt bind. blue light keep flashing and not go to a solid blue. Any idea ? ( i fly without any problem my nano QX + hoten X with deviation 3.0.0 naughty build and my devo8) . Thx for help
Last edit: 31 Jul 2013 22:18 by thibaut47.

Please Log in or Create an account to join the conversation.

More
31 Jul 2013 22:33 - 31 Jul 2013 22:47 #12671 by goebish
Replied by goebish on topic Hubsan X4 config
Do you have an additional A7105 module in your Devo 8 ?

If not then you can't bind with a hubsan X4 ....



Last edit: 31 Jul 2013 22:47 by goebish.

Please Log in or Create an account to join the conversation.

More
31 Jul 2013 22:51 #12672 by thibaut47
Replied by thibaut47 on topic Hubsan X4 config
i have not. :( thx you for the answer !

Please Log in or Create an account to join the conversation.

More
31 Jul 2013 22:54 #12673 by goebish
Replied by goebish on topic Hubsan X4 config
If you know how to handle a soldering iron this is not difficult to do at all.

Details here:
www.deviationtx.com/repository/Documenta...uleInstallation.pdf/

You can get the module for $10-$15 (ebay A7105 500m).

Please Log in or Create an account to join the conversation.

More
31 Jul 2013 23:11 #12674 by thibaut47
Replied by thibaut47 on topic Hubsan X4 config
ok ! i will take a look. thx again :)

Please Log in or Create an account to join the conversation.

More
01 Aug 2013 02:33 #12675 by sbstnp
Replied by sbstnp on topic Hubsan X4 config
Naughty build LOL :silly:

Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum