Any One Have A Blade CX2 Model

More
07 Feb 2013 03:42 #6106 by gapi
Any One Have A Blade CX2 Model was created by gapi
Any One Have A Blade CX2 Model for a Devo 10

Please Log in or Create an account to join the conversation.

More
07 Feb 2013 04:07 #6107 by Hexperience
Replied by Hexperience on topic Any One Have A Blade CX2 Model
It's a 4 channel right? So all you need to do is create a new model and select DSM2 protocol.

The defaults will take care of the rest. If you need to reduce the rates then just ask and we'll help you set that up.

There are 10 types of people in this world. Those that understand binary and those that don't.

Please Log in or Create an account to join the conversation.

More
08 Feb 2013 02:31 #6141 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Thanks!

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 16:24 #6172 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Mine will not Bind.

I just received the CX2. I loaded battery and a model and only changed it to DSM2.

The LED is blinking Red/Green

E-flight 3 in 1 Control Unit - Model EFLH1023 / Mixer Speed Control Gyro System.

Before I go claiming "Defective" what am I missing?

Thanks

Please Log in or Create an account to join the conversation.

  • rbe2012
  • rbe2012's Avatar
  • Offline
  • So much to do, so little time...
More
09 Feb 2013 16:30 - 09 Feb 2013 16:31 #6173 by rbe2012
Replied by rbe2012 on topic Any One Have A Blade CX2 Model
Have you tried to bind manually? Switch tx and heli off.
Switch tx on; wait a few second (searching for free frequencies) and go to to model config on the page, where you can change the protocol.
You will see a button labeled with "Bind" in the lower right corner.
Switch on your heli and place it on a stable surface (so that the stabilization can initialize).
Press the "Bind" button.
Does it bind after a few seocnds?
If not: what tells the manual how it should behave? Esp. which colors should the LEDs show and what does this mean?
Last edit: 09 Feb 2013 16:31 by rbe2012.

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 16:50 #6175 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
OK, I used the bind plug and gaining ground but not there yet. No throttle and reversed controls.

I have a solid red LED which means I have a bind link but the throttle and trim are not at their lowest setting. This must happen before the motors arm.

I did what the manual said to test it moving the sticks and looking at the servo arms for direction of movement and they are reversed.

So..... I need some help in the setup I guess.

Thanks

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 18:11 #6177 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Well after reading and experimenting I'll say a default DSM2 model is nowhere close to binding and flying my CX2.

I hope someone gets to look into it soon. I purchased it without a TX.

Thanks

Anything toy want me to try just let me know.

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 18:20 #6178 by sbstnp
Replied by sbstnp on topic Any One Have A Blade CX2 Model
Just reverse the 'reversed' channels and make sure Throttle is on channel 1

Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 19:42 #6179 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Thanks, I finally got that going correctly but the throttle may be the last issue.

The book says, "In order for the motors to arm":
Bind by powering the TX (The OE as delivered E-Flight TX)first
"And have the throttle and throttle trim all the way down"
Plug in the battery.

I am trying that but with no success. I still have the solid red LED indicating I have a motor enable issue.
Funny thing is I found my Throttle trim all the way down already. I do not remember doing that.


Here is the .ini. I may have the lower portion not stacked correctly.

Thanks

name=gapi's CX2
[radio]
protocol=DSM2

num_channels=7
tx_power=100mW

[channel1]
template=simple
[mixer]
src=!THR
dest=Ch1

[channel2]
reverse=1
template=simple

[mixer]
src=AIL
dest=Ch2

[channel3]
reverse=1
template=simple
[mixer]
src=ELE
dest=Ch3

[channel4]
template=simple
[mixer]
src=RUD
dest=Ch4

[trim1]
src=LEFT_V
pos=TRIMLV+
neg=TRIMLV-

[trim2]
src=RIGHT_V
pos=TRIMRV+
neg=TRIMRV-

[trim3]
src=LEFT_H
pos=TRIMLH+
neg=TRIMLH-

[trim4]
src=RIGHT_H
pos=TRIMRH+
neg=TRIMRH-

[timer2]
type=countdown
time=10

[safety]
Auto=min

[gui-qvga]
trim=4
in
barsize=half
box
1=Ch3
box
2=Timer1
box3=Timer2
bar1=Ch1
bar2=Ch2
bar3=Ch3
bar4=Ch4
toggle1=ELE
DR
tglico1=1

toggle2=AIL

DR
toggle3=RUD
DR
tglico3=2

toggle4=GEAR

tglico4=4

quickpage1=Telemetry monitor

Please Log in or Create an account to join the conversation.

More
09 Feb 2013 20:16 #6181 by sbstnp
Replied by sbstnp on topic Any One Have A Blade CX2 Model
This doesn't look right. Your throttle is reversed, so no amount of down trim will help.

[channel1]
template=simple
[mixer]
src=!THR
dest=Ch1


Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire

Please Log in or Create an account to join the conversation.

More
10 Feb 2013 04:47 - 10 Feb 2013 04:49 #6191 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Thanks, I missed that. To the point of starting again in another model file.

I do not jest when I say "I know not what I do".

I need to ask a couple things. I learn by experimentation and asking here so.......

When the CX2 is bound the LED is green.
So while stroking the throttle I notice it goes to Red and the RPM's top out much before I get to full stick.

So I experiment and find I can spread it out over the full stick movement in the Scale + setting. The Max & Min limits are 150 & -150. The Scale is also +150 -150. Via experimentation I found if I reduced the Scale+ to 35 the RPMs do not top out until the stick tops out. Same for the LED. Did I do well here?

Next I want to ask about having to reverse the Ail and Ele in order to get proper direction. Will this confuse the Gyro? I read about some Walkera helis requiring the Gyro be physically reversed on the Heli also if this is done.

Thanks
Last edit: 10 Feb 2013 04:49 by gapi.

Please Log in or Create an account to join the conversation.

More
10 Feb 2013 08:23 #6198 by sbstnp
Replied by sbstnp on topic Any One Have A Blade CX2 Model

gapi wrote: Thanks, I missed that. To the point of starting again in another model file.

I do not jest when I say "I know not what I do".

I need to ask a couple things. I learn by experimentation and asking here so.......

When the CX2 is bound the LED is green.
So while stroking the throttle I notice it goes to Red and the RPM's top out much before I get to full stick.

So I experiment and find I can spread it out over the full stick movement in the Scale + setting. The Max & Min limits are 150 & -150. The Scale is also +150 -150. Via experimentation I found if I reduced the Scale+ to 35 the RPMs do not top out until the stick tops out. Same for the LED. Did I do well here?


I think you would not normally play with Limit+/-, and scaling is used for something called 'travel adjust' which isn't very obvious on THR channel. On a channel controlling a servo you would see limited movement from the servo arm.

In the end it's just a CX2, if you like how it flies then life's good :)

Next I want to ask about having to reverse the Ail and Ele in order to get proper direction. Will this confuse the Gyro? I read about some Walkera helis requiring the Gyro be physically reversed on the Heli also if this is done.

Thanks


I don't see any issues. Is the heli flying?

Devo 10 + 4in1
Spektrum Dx9
FrSky Taranis + TBS Crossfire

Please Log in or Create an account to join the conversation.

More
10 Feb 2013 20:03 - 10 Feb 2013 20:06 #6220 by gapi
Replied by gapi on topic Any One Have A Blade CX2 Model
Yes it flies thanks. Not tested much yet. I posted the model. A moderator can delete this thread if he wants.

A video of what the Gyro effects. The gyro only controls yaw on the cx2. Motor speed.

Last edit: 10 Feb 2013 20:06 by gapi.

Please Log in or Create an account to join the conversation.

Time to create page: 0.048 seconds
Powered by Kunena Forum