SLT sub protocols

More
05 Sep 2018 19:39 - 06 Sep 2018 09:28 #70668 by planger
SLT sub protocols was created by planger
I've added in Multi sub protocols for the SLT protocol: V1, V2 and Q200.

V1 is the current implementation from deviation with support for 6 channels.
V2 is new and supports 8 channels: 4 x 10bit channels and 4 x 8bit channels. It has been tested working on SLT models including a genuine SLT Tactic TR826 RX 8 channels receiver.
Q200 is a slight variation of V2 to enable binding and flying models like the Ominus Quadcopter FPV, the Nine Eagles - FENG FPV and may be others.

Pascal
Last edit: 06 Sep 2018 09:28 by planger.

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
06 Sep 2018 09:32 #70682 by goebish
Replied by goebish on topic SLT sub protocols
I'll check that, thanks !

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
06 Sep 2018 12:22 - 06 Sep 2018 12:56 #70686 by goebish
Replied by goebish on topic SLT sub protocols
Test builds, if someone can check if it works:
www.dropbox.com/sh/ba8eas16qwlt3nh/AADUN...SHJk6CvIYyzZf-a?dl=0

New formats: V2 and Q200
V1: 6 regular channels
V2: 8 regular channels
Q200: 7 regular channels (1-8 but channel 6 is unused) + 4 extra feature channels:
Channel 9: Mode
Channel 10: Flip
Channel 11: Video on
Channel 12: Video off

source: github.com/goebish/deviation/blob/protoc...tocol/slt_nrf24l01.c
Last edit: 06 Sep 2018 12:56 by goebish.

Please Log in or Create an account to join the conversation.

More
08 Sep 2018 22:26 #70748 by etoyoc
Replied by etoyoc on topic SLT sub protocols
Is there anyway to install these builds to test without losing Hexfet's Bugs3 build?

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 07:07 #70756 by Moeder
Replied by Moeder on topic SLT sub protocols
Bugs3 protocol is included in this test build.

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 09:57 #70759 by planger
Replied by planger on topic SLT sub protocols
For the Q200 (Ominus Quadcopter FPV), CH5 is rates: +50%=min rates, 0%=mid rates (stock setting), -50%=max rates, you can adjust the value as your liking for example -20%.
CH7 and CH8 have no effect on the Ominus.
I've added a new channel for gyro calibration but it's not in the deviation build yet.

Pascal

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 11:21 #70760 by etoyoc
Replied by etoyoc on topic SLT sub protocols
I am glad the Bugs3 is included. I saw that late last night when I looked through the protocols on the zip. If that is the more recent version, then I will give this a shot. Probably can't get to it today, and even if I could, the weather isn't great for flying. It might be Tuesday or Wednesday before I can put something up in the air.

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 19:15 - 09 Sep 2018 19:38 #70762 by etoyoc
Replied by etoyoc on topic SLT sub protocols
Had a little time while the wind speeds were down. Installed protocol and it bound without issue. Was able to fly for a little bit. Had to reverse all channels.

I was having a yaw issue. I recalibrated sensors on stock transmitter. No yaw issue on the stock transmitter. Went back to the Devo and had a constant yaw. At max trim, the yaw is cancelled out.
Mode works on 9.
Flip on channel 10 works.


I removed the camera from Ominus, so I didn't check those functions.
Last edit: 09 Sep 2018 19:38 by etoyoc.

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 20:07 #70764 by planger
Replied by planger on topic SLT sub protocols
For the yaw issue, it could be that your original TX as an offset on the yaw and since it is learnt during calibration, the quad will compensate but since the Devo has no yaw offset it drifts.
Calibration is implemented in my latest code but we need to wait that someone from the deviation team includes it. It's really a few lines of code...

Please Log in or Create an account to join the conversation.

More
09 Sep 2018 20:46 - 09 Sep 2018 22:06 #70766 by etoyoc
Replied by etoyoc on topic SLT sub protocols
I had some issues with ch.5. I was using 0 (lowest rate I wanted), -25% (medium), and -50% (highest rate) as my B1, B2, and B3.

On my Ominus, my rates are flipped. When I switched to 50, 25, 0 I was much happier.
Last edit: 09 Sep 2018 22:06 by etoyoc.

Please Log in or Create an account to join the conversation.

More
11 Sep 2018 00:11 #70782 by etoyoc
Replied by etoyoc on topic SLT sub protocols
Yaw issue is gone now. I recalibrated my Devo 7e. I forgot to do a calibration after updating. That fixed it.

Wind speeds were down a little bit at sunset, so I took it out into a field. Awesome flying on max rates / acro.

Thanks for getting the sub protocol set up!

Please Log in or Create an account to join the conversation.

More
11 Sep 2018 13:40 #70799 by planger
Replied by planger on topic SLT sub protocols
I've now added more SLT sub protocols: V1, V2, Q100, Q200 and MR100.
Source is located here: github.com/pascallanger/DIY-Multiprotoco...col/SLT_nrf24l01.ino
Documentation on models, channels and tips: github.com/pascallanger/DIY-Multiprotoco..._Details.md#slt---11

Pascal

Please Log in or Create an account to join the conversation.

More
12 Sep 2018 19:07 #70850 by Moeder
Replied by Moeder on topic SLT sub protocols
Great Pascal!

Will have to wait until goebish is back from his vacation, the subprotocol additions are still in a branch in his repo, so I can't add the recent changes.

Please Log in or Create an account to join the conversation.

More
30 Oct 2018 19:25 #71507 by planger
Replied by planger on topic SLT sub protocols
Up on this post.
Goebish you need to port the SLT sub protocols I've added since your last attempt.
Pascal

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
04 Nov 2018 21:52 #71545 by goebish

Please Log in or Create an account to join the conversation.

More
07 Nov 2018 04:30 #71594 by JayDrone
Replied by JayDrone on topic SLT sub protocols
help me out here I have the sub protocols v1 v2 n q200 - i have the fpv omnimus V1 steady flashing light v2 seems to kinda bind but solid red light and i cant make motors fire -- q200 wont bind and red light just flashes - if i bind to v2 and light is steady then i can move to q200 and the led stays solid - still no motor fire acion any help would be great

Please Log in or Create an account to join the conversation.

More
07 Nov 2018 04:42 #71595 by JayDrone
Replied by JayDrone on topic SLT sub protocols
and so u all know the dfu file took out my bugs 3 min and the new eachine protocols

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
07 Nov 2018 11:05 - 07 Nov 2018 11:47 #71605 by goebish
Replied by goebish on topic SLT sub protocols

JayDrone wrote: and so u all know the dfu file took out my bugs 3 min and the new eachine protocols


That's normal, this test build was based off older sources, I just updated it (with extra SLT sub protocols):
www.dropbox.com/sh/ba8eas16qwlt3nh/AADUN...SHJk6CvIYyzZf-a?dl=0

Channel mapping:
Channel 9: Flight Mode
Channel 10: Flip
Channel 11: Video On
Channel 12: Video Off (Q200), Picture Snapshot (Q100 / MR100)
Channel 13: Calibrate (Q100 / Q200)

Try this updated version through I don't think that will change anything, that's weird that you're having those issues as @etoyoc told it was working fine on its end.
@etoyoc can you check out the updated version as well please ?
Last edit: 07 Nov 2018 11:47 by goebish.

Please Log in or Create an account to join the conversation.

More
08 Nov 2018 04:36 #71641 by JayDrone
Replied by JayDrone on topic SLT sub protocols
bam u r the man all worked out well
Attachments:

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
08 Nov 2018 13:24 #71648 by goebish
Replied by goebish on topic SLT sub protocols
Thanks!
I'm wondering why it didn't work with the first test build tho ...

Please Log in or Create an account to join the conversation.

Time to create page: 0.351 seconds
Powered by Kunena Forum