4.01 to 5 upgrade issue, Bad/or missing protocol

More
06 Oct 2019 20:40 #75193 by Frieda
Hi Everyone,

I was upgrading from 4.0.01 on the 7E, and ran smack into the Bad/or missing protocol error. To fix, I deleted the version 5 protocols, and then reintroduced the 4.0.01 protocols. I had essentially copied all files, as per the readme.

This doesn't seem proper to me. Any comments / help would be greatly appreciated. Do I need to start over? I have no extra modules, and only one model so no concerns about wiping everything clean.

I am just using USBHID right now, so not in any kind of panic.

Cheers, Freida

Please Log in or Create an account to join the conversation.

More
07 Oct 2019 04:14 - 07 Oct 2019 04:18 #75197 by vlad_vy
What firmware release do you use? Try to use:

www.deviationtx.com/forum/builds/6407-de...cols?start=500#75159

or

www.deviationtx.com/forum/builds/8508-re...ild-deviation-v5-x-x

At any case with devo7e you need update at least firmware along with 'protocol' folder. Will better completely rewrite the filesystem. Backup used model files, after update write model files back to filesystem.
Last edit: 07 Oct 2019 04:18 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
07 Oct 2019 05:17 #75202 by Frieda
Hi vlad_vy,

I used deviation-devo7e-v5.0.0-28ce50f. I thought I didn't need to do the 'upgrade firmware' step, thinking this wasn't required? All I did, was to copy all the files over.

I originally installed deviation 4.01 several years back. And, I had forgotten all the steps to install the FW. I thought the UPDATING readme, says I just need to copy the files.

Sometimes these technical documents can be a challenge to follow. :-)

Please Log in or Create an account to join the conversation.

More
07 Oct 2019 05:23 #75203 by vlad_vy
I think current nightly builds can be problematic for devo7e (and other transmitters), I suggest to use any of above builds.

Please Log in or Create an account to join the conversation.

More
07 Oct 2019 12:41 #75204 by Frieda
Ok thanks vlad_vy,
I will follow your suggestion.
Cheers.

Please Log in or Create an account to join the conversation.

Time to create page: 0.318 seconds
Powered by Kunena Forum