Add two switches to the Devo 7e

More
25 Jan 2015 19:57 #28024 by Deequeue
Replied by Deequeue on topic Add two switches to the Devo 7e
Hi HH,

Right, figured it out - I was using the standard notepad app to edit the file - happened across the fact that most of you guys on here use Notepad++ to edit files.


That was the issue, edited, now working :)


Dale

Please Log in or Create an account to join the conversation.

More
29 Jan 2015 11:29 #28200 by Gerhard_H
Replied by Gerhard_H on topic Add two switches to the Devo 7e
Hi !
Also had done the switches-mod with my Devo7E.
I had taken 2 (pcs) of 3-way-switches (on-off-on).
I assume soldering is OK. But as I had expected there are no additional entrys in the tx-menu.
Therefore my question is how should the hardware.ini look like.
Are both lines necessary ("switch_types:...." and "extra_switches=....") ?
How does "switch_type" look like in my case ?
And I assume "extra_switches" are these two additional switches, right ?
Therefore "additional_switches=2"
Right ?
Remark : FW is the last nightly build.

TIA
Gerhard

Please Log in or Create an account to join the conversation.

More
29 Jan 2015 13:35 #28203 by aMax
Replied by aMax on topic Add two switches to the Devo 7e
extra-switches=3x2

Devo7e, TaranisQ X7, R9M , 4in1 MM, Futaba FC18plusV3.2 & DFT/FLD-02

Please Log in or Create an account to join the conversation.

More
20 Apr 2015 11:58 #31410 by afterdub
Replied by afterdub on topic Add two switches to the Devo 7e
Hi All,

I just do the 3x2 switch mod, use the last build nightly "deviation-devo7e-v4.0.1-67b36f4" modify the "hardware.ini" to "extra-switches=3x2"
edit with notepad++.
But can't see the extra switches in the devo7e.
Seem the hardware mod in ok, i can use switch with an older build patched witch show "ELE DR" and "AIL DR" in switch choice.
But how i can get the switch work with SW A0/A1/A2?
I try everything i can ,i just can figure out!

Help will be very apprecied, and many thanks for all the works you do guys.
Jm

Please Log in or Create an account to join the conversation.

More
20 Apr 2015 13:40 #31417 by PhracturedBlue
Replied by PhracturedBlue on topic Add two switches to the Devo 7e
show us your hardware.ini
when you go the the test screen can you see inputs SWA and SWB show up (Tranmitter menu-> Channel Monitro->Stick inputs)
if it isn't there then your hardware.ini is the most likely culprit. If it is there, make sure the switches work

Please Log in or Create an account to join the conversation.

More
20 Apr 2015 18:00 #31432 by afterdub
Replied by afterdub on topic Add two switches to the Devo 7e
I just find how to enable switch, I just remove the " ; " before extra switch=3x2.
Now it's all good i can see the switch in the monitor channel.
Thx.

Please Log in or Create an account to join the conversation.

More
24 Apr 2015 14:28 #31569 by Henne22
Replied by Henne22 on topic Add two switches to the Devo 7e
Hey ,
it is possible to add a rotary knob to the devo 7e?

Please Log in or Create an account to join the conversation.

More
24 Apr 2015 22:49 #31584 by Arakon
Replied by Arakon on topic Add two switches to the Devo 7e
Sure, but it wouldn't have any function.
There's no easily accessible analog input available, unfortunately.

Please Log in or Create an account to join the conversation.

More
26 Apr 2015 13:40 #31643 by Henne22
Replied by Henne22 on topic Add two switches to the Devo 7e
thats a pity, thanks anyway!

Please Log in or Create an account to join the conversation.

More
08 May 2015 14:45 - 08 May 2015 14:48 #32250 by Hr
Replied by Hr on topic Add two switches to the Devo 7e
Hi
I have the same problem with the switches mod.
The do not show up.I am training to find if the problem is the wiring or the hardware.
I disconnected all extra switches wiring .
Is the SWA and SWB should show up in the TR menu with out the extra switches wired ??
Attached my file
Attachments:
Last edit: 08 May 2015 14:48 by Hr. Reason: Added file

Please Log in or Create an account to join the conversation.

More
16 May 2015 07:43 #32641 by Hr
Replied by Hr on topic Add two switches to the Devo 7e
Dear friends any helpful answer???

Please Log in or Create an account to join the conversation.

More
16 May 2015 10:42 #32644 by robca
Replied by robca on topic Add two switches to the Devo 7e
It would be better if you copied the hardware.ini file in the message, easier to read than an upside-down picture :)

Also, probably a wiring problem, so a picture of your solder points and the switches/diodes used would help

Please Log in or Create an account to join the conversation.

More
16 May 2015 12:54 - 16 May 2015 12:59 #32645 by Hr
Replied by Hr on topic Add two switches to the Devo 7e

File Attachment:

File Name: tx-2.ini
File Size:4 KB


File Attachment:

File Name: tx-2.ini
File Size:4 KB


herethe ini file from my 7e and wirinig pictures dut cant see any new switches




Attachments:
Last edit: 16 May 2015 12:59 by Hr.

Please Log in or Create an account to join the conversation.

More
16 May 2015 15:58 - 16 May 2015 15:58 #32647 by TomPeer
Replied by TomPeer on topic Add two switches to the Devo 7e
You are running Deviation 4.0.1, the switches do not work with this firmware.
Install the latest nightly built.
than change the hardware.ini file (not tx.ini) like the one in your upside-down picture.

good luck

PS the wiring looks good.
Last edit: 16 May 2015 15:58 by TomPeer.

Please Log in or Create an account to join the conversation.

More
17 May 2015 06:09 #32682 by Hr
Replied by Hr on topic Add two switches to the Devo 7e
Thank you
I instaiied deviation-devo7e-v4.0.1-92a2f2f
And it is workinig.

Please Log in or Create an account to join the conversation.

More
23 Jun 2015 18:26 - 23 Jun 2015 18:27 #34560 by Lachemou
Replied by Lachemou on topic Add two switches to the Devo 7e
Hello my friends,

i have successfully modded my devo 7e ! Thanks a lot for this mod !
i have added 2 switches with 3 positions.
So now i have a SWA et SWB with 100 0 -100 positions ;) it works

i would like to use :
1 channel for change the mode : Attitude, Rattitude, Accro
1 channel for : Armed, disarmed and alarm buzzer
1 channel for : RTH (when it will be available with openpilot)
1 channel for : Keep Position (when it will be available so)
is it possible ?

I have bought a RX701 receiver i think i can't do this with this receiver if i have all understand ! Can you confirm ? What is the most appropriate receiver ?

Another question, a friend use a tanaris X9D with CC3D and on this receiver it can show the distance between us and the quad, is this possible to do the same with our devo ? it will be wonderful ;)

Thanks a lot for your help and sorry for my bad english
Last edit: 23 Jun 2015 18:27 by Lachemou.

Please Log in or Create an account to join the conversation.

More
29 Jul 2015 04:40 - 29 Jul 2015 08:06 #36286 by mickkn
Replied by mickkn on topic Add two switches to the Devo 7e
Hello. I would like to know if it's even possible to add or exchange one of the 2-way switches to a 3-way switch. And have it working with rx701. Does it not come short of channels?
Last edit: 29 Jul 2015 08:06 by mickkn.

Please Log in or Create an account to join the conversation.

More
29 Jul 2015 11:45 #36298 by mwm
Replied by mwm on topic Add two switches to the Devo 7e
Well, you could always use a 3 position flight mode switch for three flight modes instead of two without using any extra channels. The Devo 6 comes with two 2 way and two 3 way switches

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
07 Sep 2015 19:39 - 07 Sep 2015 19:47 #37541 by IKKI
Replied by IKKI on topic Add two switches to the Devo 7e
Thanks a lot guys, following your guide I managed to add the 3 x 2 switches. Also I wanted to add a button connected to FMODE to perform the flip or more quickly. Works great!

:woohoo:
Attachments:
Last edit: 07 Sep 2015 19:47 by IKKI.

Please Log in or Create an account to join the conversation.

More
13 Nov 2015 15:37 #40012 by anansi22
Replied by anansi22 on topic Add two switches to the Devo 7e
Hi, after having extensively researching and checking wiring, parts used, and mixes, I have an issue with this mod.

The left switch - SW A0, A1, A2, works as expected producing values of -100 to 100 when switched from top to bottom. With mixing I'm able to get the three positions. I can see the channel 5 moving from 100 to 0 to -100, so this one clearly works.

My other switch - SW B0, B1, B2 produces only values of 100 and -100 on B0 and B2, with no deflection on B1. B1 stays pegged at -100 and does not move through the three switch positions.

I verified wiring and tested in the deflections in the channel monitor. I also checked the (on off on) SPDT switches with a continuity checker to make sure my switches work the same. I verified the diodes and replaced them on that switch twice - now using regular signal diode NTE116 ( similar to the 1N4001).

A bit about me: I have years experience in electronic project building and modifications. I've check and recheck all more than once.

B1 did work with an earlier build but I can't remember which it was. I'm running the latest nightly.

Thanks

Please Log in or Create an account to join the conversation.

Time to create page: 0.094 seconds
Powered by Kunena Forum