Jumper T8SG PLUS stopped working after FW upgrade

More
07 Nov 2019 04:34 #75416 by Crzyruss80
Replied by Crzyruss80 on topic Jumper T8SG PLUS stopped working after FW upgrade
Mine is stuck in upload mode with the usb symbol if i go to exit you can see a quick screen that looks like its loading something can anybody send a link on how to get out of this screen this is my 2nd T8SG they are killing me its been working for a week w three different quads then the only thing i can think is that i accidentally tapped the power button to quick and put in this mode?

Please send link stuck w usb screen red and green lights on no other buttons work

Please Log in or Create an account to join the conversation.

More
13 Jun 2020 00:16 #76463 by artest7
I know this is 2 years old but were u ever able to fix your Jumper T8SG Plus BLANK SCREEN issue? I'm having the same problem with mine and ANY help will bwe MUCH appreciated!
Thank you,
Art

Please Log in or Create an account to join the conversation.

More
13 Jun 2020 00:17 #76464 by artest7
Which Firmware is the correct one to Flash to my Jumper T8SG Plus V2 please? I have a blank screen on mine too and cannot seem to find any support.
Thank you!

Please Log in or Create an account to join the conversation.

More
16 Jun 2020 10:35 #76480 by sansjunk
Flash t8sg_v2_plus if you have an OLED screen (white pixels on dark background) and t8sg_v2 if you have a regular LCD display (black pixel on light background).

Please Log in or Create an account to join the conversation.

More
23 Jul 2020 00:04 #76602 by fmurray

sansjunk wrote: Flash t8sg_v2_plus if you have an OLED screen (white pixels on dark background) and t8sg_v2 if you have a regular LCD display (black pixel on light background).


This happened on my v3. And your fix worked. Thank you.

Please Log in or Create an account to join the conversation.

Time to create page: 0.051 seconds
Powered by Kunena Forum