×
Important information

To file a bug, find instructions here: Reporting bugs

Please only post images or files to this forum which you either own the copyright to or you are sure can be distributed under an open source license.

Jumper T8SG PLUS stopped working after FW upgrade

More
14 May 2018 19:01 #69219 by momen
After I did upgrade to my new Jumper T8SG PLUS it stopped working, when i turn it on nothing show up just empty black screen and also no sound from buzz when i move the trims buttons, please see the attached photo.

I used the uploader 0.8.0 (in my mac) with 05-13-2018 build (deviation-devo7e-256-v5.0.0-f17ed68.zip) then the issue happen.
I also tried other stable build for devo7e (when I connect tp uploader i see Devo 7e not T8SG) but still same issue and I tried nightly build from 05-13-2018 that says t8sg insted of devo7e and I tried with format option as well but still same issue.

At least I still can connect it to uploader and do update and see the files in file manager but when i turn it on to normal use without holding EXT then it is not working.

Any one faced same issue with Jumper T8SG PLUS ? or if you know anything that may help ?
Attachments:

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
14 May 2018 19:44 - 14 May 2018 19:58 #69220 by goebish
You shouldn't flash a 7e or t8sg v1 firmware to a t8sg v2 plus.
Check out this one instead ;)
[removed]
Last edit: 14 May 2018 19:58 by goebish.

Please Log in or Create an account to join the conversation.

More
14 May 2018 19:56 #69221 by momen
First try didn't work but after I used the uploader 0.9.0 then it worked.

I found the uploader 0.9.0 from this topic by (vlad_vy) i also noticed the same FW you shared there:
www.deviationtx.com/forum/builds/7748-ju...uilds?start=20#69209

Issue solved :)

Regards.

Please Log in or Create an account to join the conversation.

  • goebish
  • goebish's Avatar
  • Away
  • I Void Warranties
More
14 May 2018 19:58 #69222 by goebish
Ok, I'll remove my link then, better check Vlad's topic for now :)

Please Log in or Create an account to join the conversation.

More
05 Aug 2018 22:56 #70125 by Natterjak2017
Replied by Natterjak2017 on topic Jumper T8SG PLUS stopped working after FW upgrade
I have just ended up in the same position as yourself,after firmware upgrade i now have a black screen with just the red light on the power button and i can no longer connect to the computer in Dfu mode or and mode for that matter..Very disappointed with this radio as it arrived just a few days ago stuck in usb mode,Looks like garbage if you ask me...

Please Log in or Create an account to join the conversation.

More
06 Aug 2018 17:05 #70136 by ScottyK
I have Jumper T8SG V2 and loaded the Bugs 3 Hexfet test build Hexfet firmware t8sg_v2-v5.0.0-dc7544a bugs3. It has been working flawlessly ever since. Make sure you flash only T8SG V2 Plus files.

Please Log in or Create an account to join the conversation.

More
06 Aug 2018 22:24 #70140 by Natterjak2017
Replied by Natterjak2017 on topic Jumper T8SG PLUS stopped working after FW upgrade
Thankfully i sorted the flashing last night,problem was my computer for some reason would not allow me to format the on board files so i tried on another laptop i have and it formatted right away,once i had that done the new firmware went on no problem and it seems to be working fine now,havent flown it yet but arming switches ect are spot on..Thanks for your input man
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Aug 2018 23:19 #70335 by Jimbuck
did you back up the stock files first? if so you can reboot to them

Please Log in or Create an account to join the conversation.

More
18 Aug 2018 23:24 #70336 by Jimbuck
i have been trying to load the bugs 3 on my v2 plus with no luck could you help

Please Log in or Create an account to join the conversation.

More
18 Aug 2018 23:26 #70337 by Jimbuck

ScottyK wrote: I have Jumper T8SG V2 and loaded the Bugs 3 Hexfet test build Hexfet firmware t8sg_v2-v5.0.0-dc7544a bugs3. It has been working flawlessly ever since. Make sure you flash only T8SG V2 Plus files.

how do i do this

Please Log in or Create an account to join the conversation.

More
19 Aug 2018 03:44 #70338 by ScottyK
This is how I did it.
The latest Bugs 3 version has changed www.deviationtx.com/downloads-new/catego...exfet-protocol-bugs3 Make sure you down load the proper version V2...V2Plus depending on your model. You gotta check out jaydrone he is the man when it comes the jumper set up videos. Thank you Jay

Please Log in or Create an account to join the conversation.

Time to create page: 0.239 seconds
Powered by Kunena Forum