Devo7e - 4in1 - S-FHSS - Frequency Issue

More
18 Mar 2017 08:21 #60314 by Gerhard_H
Devo7e - 4in1 - S-FHSS - Frequency Issue was created by Gerhard_H
Hi !
I have a Devo7e and the 4in1 module.
S-FHSS works (binds) sometimes, sometimes not. I'd found by chance that there's a sub menu which offers setting of Frequ-Fine and Frequ-Coarse.
I own several helis using the Futaba protocol, some have a bind knob, some haven't.
There are XK K123 (AS 350), XK K100, XK K110.
Unluckily haven't found any info how to deal with these parameters (maybe I remember to read some discussion covering this issue but I'm not sure). Search didn't find nothing (Frequ-Fine Frequ-Coarse).
Any advice would be highly appreciated.
Kind regards
Gerhard

Please Log in or Create an account to join the conversation.

More
18 Mar 2017 09:54 #60318 by mwm
You should just need to adjust the fine frequency. You have to do it for each model, since the exact value varies from manufacturer to manufacturer of both the model and rf module in your Tx.

Range is from -128 to +127, defaulting to 0. Try adjusting it by steps of 10 or 20 until it binds. Once it's bound, keep stepping the value until the connections fails. Then set it to half-way between those two values.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
18 Mar 2017 10:16 #60323 by mwm
I just added this instructions to the wiki page at www.deviationtx.com/wiki/modulelist/cc2500 . If others could check it out and fix any mistakes, I'd appreciate it .

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
19 Mar 2017 03:21 #60355 by Gerhard_H
Replied by Gerhard_H on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Thanks a lot !
Just as I suspected.
But :
With one of my helis it worked nearly instantly, with others not at all . . .
So for me the question seems to be : How long does it normally take to bind ? Or, to say in other words, how long have I to wait between every step ?
TIA
Gerhard

Please Log in or Create an account to join the conversation.

More
19 Mar 2017 17:18 #60372 by mwm
Depends on the receiver and protocol. And of course the Fine setting. My FrSky Rx's bind really quickly once things are set right. The one XK I have is a bit slower, but still faster than the Spectrum Rx's (which use the CYRF chip).

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
19 Mar 2017 18:13 #60373 by Gerhard_H
Replied by Gerhard_H on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Thx, I see - I'd checked with a Futaba T14SG radio, which binds nearly initially with the heli. Tried again with the Devo but without any success. Therefore tried to continue with Frequ Coarse set on 1 but no chance also.

Please Log in or Create an account to join the conversation.

More
22 Mar 2017 02:42 #60497 by flarkopter
Replied by flarkopter on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
I remember having a similar issue on my devo 7e with 3-in-1 in combination with a XK X251.
Had to set Coarse to +40, Fine was not used. Just keep trying some values, you should get it in the end. Not every module has the exact same specs.

Please Log in or Create an account to join the conversation.

More
22 Mar 2017 05:20 #60500 by Gerhard_H
Replied by Gerhard_H on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Coarse +40 ?!!! That's really interesting !
Think I've got a lot to do . . . ;)

Please Log in or Create an account to join the conversation.

More
30 Mar 2017 06:49 #60938 by Gerhard_H
Replied by Gerhard_H on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Unluckily there's still no chance to bind one of my AS350 (XK K123) with my Devo 7e.
I own 4 AS350, there's an elder one with the WLToys protocol and three with the Futaba S-FHSS.
An interesting detail is that one of these three RX doesnt have a bind button. And exactly this is the heli which causes troubles.
As I had mentioned earlier, I also own a Futaba T14SG radio - with this radio the heli binds instantly !
On the other hand - the Devo7e's S-FHSS frequency options offer 256 fine and 256 coarse tuning steps.
I really don't want to have to wander through 256x256 setting steps . . .
I do suspect that the signal from the Futaba radio contains an additional "special" tag which tells the actual RX (which also seems to be a "special" one) "Hey, listen, I'm a genuine Futaba radio" . . .
What do you folks think ?

Please Log in or Create an account to join the conversation.

More
31 Mar 2017 00:03 #60960 by mwm
You shouldn't need to go through 256 settings. Coarse is normally 0, I don't recall seeing any reports of it needing to be changed. Receivers tend to bind if Fine is within a value of 20 or so of optimal, so moving it 20 at a time should work if it's going to work at all.

And it's thoroughly possible that there's some value that model looks for that other models don't use and we don't get right. The only way to tell is to get captures from your Tx SPI bus to examine.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
31 Mar 2017 03:50 #60965 by Gerhard_H
Replied by Gerhard_H on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Thx a lot !

mwm wrote: . . . The only way to tell is to get captures from your Tx SPI bus to examine.

I'm sorry but I don't know how to do so. No idea what a SPI bus is.
Any advice would be highly appreciated.
TIA

Please Log in or Create an account to join the conversation.

More
31 Mar 2017 08:11 #60970 by mwm

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
22 Jul 2018 18:32 #69919 by LeGriffon
Replied by LeGriffon on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Hi,

I have the same problem. I already got a XK K120 & K123, just receive the K124 and this one refuse to bind. I try to add fine tuning of freq like that :

name=XK K124 EC145
mixermode=Advanced
icon=XK-K124.BMP
[radio]
protocol=S-FHSS
num_channels=8
fixed_id=545467
tx_power=150mW

[protocol_opts]
Freq-Fine=120
Freq-Coarse=0

I tryed freq-fine from -120 to 120 by steps of 20, with no result... I did it by editing the ini file on the PC, save, switch off switch on radio (to go out usb mode)... turn on the heli, press the bind button, wait 5 seconds... nothing... switch off, switch on USB mode, edit again... and so on... it's really long (and frustrating!). Any way to change the freq-fine from the devo ? (I use a devo 6 with touch screen). Or to know what values to use ?

thanks in advance for help.

Rgds,
Pascal.

Please Log in or Create an account to join the conversation.

More
22 Jul 2018 21:32 #69922 by gdenton
Replied by gdenton on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
On the 'Model setup' page tap 'S-FHSS' and you should see the adjustment settings.

Please Log in or Create an account to join the conversation.

More
24 Jul 2018 14:56 - 24 Jul 2018 14:59 #69949 by LeGriffon
Replied by LeGriffon on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
I don't know if it is because I use a DEVO 6 but there is no adjustment settings on my Model Setup page.
I also try to put the lines :

[protocol_opts]
Freq-Fine=120
Freq-Coarse=0

in my other models ini files, this does not change anything they still binding with no trouble... Like if these lines got no effect... is it the good syntax ?

Rgds,
Pascal.
Last edit: 24 Jul 2018 14:59 by LeGriffon.

Please Log in or Create an account to join the conversation.

More
24 Jul 2018 22:53 #69956 by gdenton
Replied by gdenton on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
What firmware version are you using?
Your syntax looks correct.

Did you try what I said?
Go to the 'Model setup' page.
If you have a touchscreen press or tap 'S-FHSS'.
Or use the UP+/DN- buttons to highlight 'S-FHSS' and then press the ENT button.

Please Log in or Create an account to join the conversation.

More
27 Jul 2018 08:16 #69968 by LeGriffon
Replied by LeGriffon on topic Devo7e - 4in1 - S-FHSS - Frequency Issue
Hi,

Thanks for help, but I try it, there is no sub menu (or anything) then you tap or try ENT on S-FHSS, unfortunately.

Rgds
Pascal.

Please Log in or Create an account to join the conversation.

Time to create page: 0.271 seconds
Powered by Kunena Forum