Blade 200QX

More
21 Dec 2015 08:11 - 24 Dec 2015 17:54 #41080 by ursus69
Replied by ursus69 on topic Blade 200QX
Hey!

┬┐Someone have the .ini for the 200QX for the 7E?...with the flight modes in the SWB?? and trottle cut in Hold?

Thanks!!
Regards and merry christmas!!
Last edit: 24 Dec 2015 17:54 by ursus69.

Please Log in or Create an account to join the conversation.

More
26 Dec 2015 18:44 #41157 by ursus69
Replied by ursus69 on topic Blade 200QX
Any help??

Please Log in or Create an account to join the conversation.

More
27 Dec 2015 00:07 #41163 by nwoodschris
Replied by nwoodschris on topic Blade 200QX
I don't use a Devo 7, I use the 10 so I cannot help but I will say that reading MWM's tutorial on how to write a config was both interesting and helpful and I am still a newbie but learning to write my own was very helpful. Maybe you could read it and start with the Devo 10 config and figure out how to change it. I think if you are worried about the mode switching if you just have the last 2 modes it's all I ever use (the high angle stabilized and then without stabilization) so that part is no big deal. The sticky throttle hold is great! Sorry I can't be more helpful but just to say that if you try it's not as intimidating as it seems and if you start a config then come to a roadblock people seem to really help out. Good luck!

Please Log in or Create an account to join the conversation.

More
28 Dec 2015 07:58 #41192 by ursus69
Replied by ursus69 on topic Blade 200QX
Hi nwoodschris!
Thanks for your help! I have the MWM's tutorial, and I started to read it...
I'll try to create one, but I need more time...
I was just wondering , if anyone had a 7E .ini, to fly well... and then I will do my newbie tests :P

Please Log in or Create an account to join the conversation.

More
28 Dec 2015 17:09 #41198 by NinerRider
Replied by NinerRider on topic Blade 200QX
Sorry haven't followed this thread in a while, never got it to work well with Devo 7 so I needed up getting a Devo 10.
Good Luck!

Please Log in or Create an account to join the conversation.

More
29 Dec 2015 21:01 #41255 by ursus69
Replied by ursus69 on topic Blade 200QX
Hi!! I need help :P i'm very .ini noob...
I tried a .ini for my Devo7E, and works half...

- The HOLD works ok (start and stop engines)
- The SWA change the flight modes, but not in order :( SWA0 (blue), SWA1 (red), SWA2 (green)..... I tried to change it..with no luck... ┬┐How can I change it to have swa0 green, swa1 blue, swa2 red??
- How I have to do, to have a dual rate (70% & 100%) in FMODE switch or SWB switch??

I attach the .ini file

Any help would be welcome!
Thanks!!
Attachments:

Please Log in or Create an account to join the conversation.

More
29 Dec 2015 21:56 #41258 by Deal57
Replied by Deal57 on topic Blade 200QX
I don't have a 200QX, but I can see a couple of problems with the mixers. The original ini in this thread is pretty complicated, and it looks to me like you've migrated most of it. Maybe I can help with the channel 2 (aileron) settings. You can also set up channel 3 (elevator) to match, if desired -- the original file used data rate switches for each independently, but with the 7e we just don't have that luxury!

In you channel 2 mix, you seem to want to have three rates:
[channel2]
template=expo_dr
[mixer]
src=AIL
dest=Ch2
[mixer]
src=AIL
dest=Ch2
switch=SW A1
scalar=70
[mixer]
src=AIL
dest=Ch2
switch=SW B0

But you are using two switches (SWA and SWB) to set rates, and I don't think you'll get the results you want. Presuming switch SWA is a 3-position switch, you could use it this way to have a 100% rate on position 0, 90% on position 1 and 70% on position 2:
[channel2]
template=expo_dr
[mixer]
src=AIL
dest=Ch2
[mixer]
src=AIL
dest=Ch2
switch=SW A1
scalar=90
[mixer]
src=AIL
dest=Ch2
switch=SW A2
scalar=70

If you just want two rates, remove one of the mixers. Let us know what you do!

Deviation Devo7e 3way switch mod, A7105, NRF24L01
Devo6s 2x2 switch mod, trim mod, haptic, multimodule, A7105, NRF24L01, CC2500
Devo12e 4-in-1 with voice mod -- it speaks!!

Please Log in or Create an account to join the conversation.

More
30 Dec 2015 08:23 #41259 by ursus69
Replied by ursus69 on topic Blade 200QX
Hi Deal57! I will try when I get home!

- I have 3 flight modes in SWA, but not in order...SWA0 (blue), SWA1 (red), SWA2 (green)....the correct order will be SWA0 (green-low angle), SWA1 (blue-high angle), SWA2 (red-acro mode)....How can I change it?
- In each mode , could change the rate (70% or 100%) with FMODE switch?? How?

Thanks for your help Deal57!!

Please Log in or Create an account to join the conversation.

More
05 Jan 2016 07:12 #41393 by ursus69
Replied by ursus69 on topic Blade 200QX
Any ideas?

Thanks!

Please Log in or Create an account to join the conversation.

More
05 Jan 2016 12:05 - 05 Jan 2016 12:05 #41401 by Deal57
Replied by Deal57 on topic Blade 200QX
In the tutorial section under Index above, you'll see an awesome tutorial called "writing a deviationTX model", written by MWM. About half way through he discusses the 200qx flight modes. This should cover your questions, but let us know if you have questions.

Deviation Devo7e 3way switch mod, A7105, NRF24L01
Devo6s 2x2 switch mod, trim mod, haptic, multimodule, A7105, NRF24L01, CC2500
Devo12e 4-in-1 with voice mod -- it speaks!!
Last edit: 05 Jan 2016 12:05 by Deal57.

Please Log in or Create an account to join the conversation.

More
10 Jun 2016 07:15 #50317 by Infamous2117
Replied by Infamous2117 on topic Blade 200QX
I am reasonably new to deviation but i am about to purchase or devo 10 for use with my 200qx

I have a couple of questions that i am not really clear on and i hope somebody can help

I read that to arm it, its the usual bottom left to right throttle process but what is the disarm on a devo 10?

Also i am seeing multiple modified .ini files in here, is there any one i in particular i should be using? As far as i can tell everybody is just modifying the 350 qx ini, i would mainly be using BLUE mode in high rates but of course i want 3 flight modes.

Which brings me to my next question does the Devo 10 have stock 3 lvl switches for flight modes?

I am just not sure which ini file i should be using, Apologies if my questions seem vague i am just trying to clarify. Google only brings up so many answers.

Please Log in or Create an account to join the conversation.

More
10 Jun 2016 20:25 #50350 by mwm
Replied by mwm on topic Blade 200QX

Infamous2117 wrote: I read that to arm it, its the usual bottom left to right throttle process but what is the disarm on a devo 10?


Whatever they recommend for other computerized transmitters will work. I think it's just lowering the throttle trim enough. But that's doing it the hard way. I'm going to attach my model.ini to this message. If you use that, it will arm when you shift the RUD DR switch from 0 to 1, and then disarm (and turn on the throttle hold) when you go from 1 back to 0.

Also i am seeing multiple modified .ini files in here, is there any one i in particular i should be using? As far as i can tell everybody is just modifying the 350 qx ini, i would mainly be using BLUE mode in high rates but of course i want 3 flight modes.


The 200Qx is very similar to the 350Qx V1 firmware, and the modified versions work fine, though RTH doesn't work and the panic switch has to be done in the transmitter. Later version of the 350Qx added more flight modes. The one attached was developed from scratch for my tutorial on deviationTx models . That explains how the model works, which should teach you enough that you change it to meet your needs if it doesn't.

A warning: when in "blue" mode, it will automatically switch to "red" mode when you give it sufficient cyclic, where "sufficient" is controlled by AUX5. So as a safety feature, if you enable this model (either turn on the Tx with it active, or load it from the model menu) with AUX5 not at 0, it will give you a warning. At 0, it never automatically switches to "red" mode. This automatic switch is not supported by HH, and there are some reports of it making the 200Qx's problem with losing gyro calibration worse, though I've never had a problem. But it's also very cool, letting you set up the 200Qx with either "automatic flip" when you give it full cyclic by just nudging it up a little, or an "auto-leveling" agility mode if you turn it all the way up.

Which brings me to my next question does the Devo 10 have stock 3 lvl switches for flight modes?


Yes. It's even called "FMODE". There's also a 3-way MIX switch. The other four switches (AIL DR, RUD DR, ELE DR and GEAR) are 2-way.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.
Attachments:

Please Log in or Create an account to join the conversation.

More
10 Jun 2016 23:06 #50368 by Infamous2117
Replied by Infamous2117 on topic Blade 200QX
Thank you your response was very clear and helpful and will make things a lot easier for me.

Please Log in or Create an account to join the conversation.

More
13 Jun 2016 15:27 #50544 by ursus69
Replied by ursus69 on topic Blade 200QX

mwm wrote:

Infamous2117 wrote: I read that to arm it, its the usual bottom left to right throttle process but what is the disarm on a devo 10?

This automatic switch is not supported by HH, and there are some reports of it making the 200Qx's problem with losing gyro calibration worse, though I've never had a problem.


I use your 200qx .ini (post #24659) and sometimes in "stagility mode" after a flip, I have a gyro problems and no stabilize well..

Please Log in or Create an account to join the conversation.

More
20 Jun 2016 09:48 #50853 by Infamous2117
Replied by Infamous2117 on topic Blade 200QX

mwm wrote:

Infamous2117 wrote: I read that to arm it, its the usual bottom left to right throttle process but what is the disarm on a devo 10?


Whatever they recommend for other computerized transmitters will work. I think it's just lowering the throttle trim enough. But that's doing it the hard way. I'm going to attach my model.ini to this message. If you use that, it will arm when you shift the RUD DR switch from 0 to 1, and then disarm (and turn on the throttle hold) when you go from 1 back to 0.

Also i am seeing multiple modified .ini files in here, is there any one i in particular i should be using? As far as i can tell everybody is just modifying the 350 qx ini, i would mainly be using BLUE mode in high rates but of course i want 3 flight modes.


The 200Qx is very similar to the 350Qx V1 firmware, and the modified versions work fine, though RTH doesn't work and the panic switch has to be done in the transmitter. Later version of the 350Qx added more flight modes. The one attached was developed from scratch for my tutorial on deviationTx models . That explains how the model works, which should teach you enough that you change it to meet your needs if it doesn't.

A warning: when in "blue" mode, it will automatically switch to "red" mode when you give it sufficient cyclic, where "sufficient" is controlled by AUX5. So as a safety feature, if you enable this model (either turn on the Tx with it active, or load it from the model menu) with AUX5 not at 0, it will give you a warning. At 0, it never automatically switches to "red" mode. This automatic switch is not supported by HH, and there are some reports of it making the 200Qx's problem with losing gyro calibration worse, though I've never had a problem. But it's also very cool, letting you set up the 200Qx with either "automatic flip" when you give it full cyclic by just nudging it up a little, or an "auto-leveling" agility mode if you turn it all the way up.

Which brings me to my next question does the Devo 10 have stock 3 lvl switches for flight modes?


Yes. It's even called "FMODE". There's also a 3-way MIX switch. The other four switches (AIL DR, RUD DR, ELE DR and GEAR) are 2-way.


So i dont want it to switch to red mode which setting do i set to zero?

EG

[mixer]
src=AUX5
dest=Virt2
scalar=50
offset=-52
usetrim=0
muxtype=add

[virtchan3]
name=St. Dial
template=simple
[mixer]
src=AUX5
dest=Virt3
scalar=-50
offset=51

[safety]
Auto=min
AUX5=min

I am going to have another read of that tutorial, but i wasnt sure which "AUX5" section of the ini i should be changing.

Please Log in or Create an account to join the conversation.

More
20 Jun 2016 10:27 #50854 by mwm
Replied by mwm on topic Blade 200QX
Ah, I see the source of your confusion. AUX5 isn't a setting in the model file but the extra analog input on the right shoulder knob.

I haven't been flying due to a combination of health and weather, and have forgotten which direction is which. But if you load the model (or turn it on with that model selected) and don't get a warning, then it won't change modes automatically. If you get the warning about AUX5, twist the AUX5 knob until the warning goes away, and it again won't change modes automatically.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
20 Jun 2016 10:38 #50855 by Infamous2117
Replied by Infamous2117 on topic Blade 200QX

mwm wrote: Ah, I see the source of your confusion. AUX5 isn't a setting in the model file but the extra analog input on the right shoulder knob.

I haven't been flying due to a combination of health and weather, and have forgotten which direction is which. But if you load the model (or turn it on with that model selected) and don't get a warning, then it won't change modes automatically. If you get the warning about AUX5, twist the AUX5 knob until the warning goes away, and it again won't change modes automatically.


Ah now i get you, so the physical AUX5 knob controls it, good to know.

Thanks i hope your health gets better buddy.

Please Log in or Create an account to join the conversation.

More
27 Jun 2016 08:30 - 27 Jun 2016 09:50 #51109 by Infamous2117
Replied by Infamous2117 on topic Blade 200QX
Hey mate, No matter what i do it turns red when i give full cyclic.

Not sure what i am missing, i tried turning the AUX5 knob to 0 but the warning stays,

I just want to be able to fly it in blue mode without doing autoflips.

Can i change this in the .ini?

EDIT: Nevermind the issue was the AUX 4 and AUX 5 knobs were not calibrated correctly. All fixed, flys great.
Last edit: 27 Jun 2016 09:50 by Infamous2117.

Please Log in or Create an account to join the conversation.

More
14 Aug 2016 18:43 #52752 by aswin1
Replied by aswin1 on topic Blade 200QX
Hi Folks, i'm looking to upgrade my transmitter from a Devo 7E to a Devo 10, to fly with my 200qx and smaller qx quads on DSM2/X with the latest Deviation installed.

I just need the 3 basic flight modes (no stagility, etc.) as smooth and solid/'locked in' a possible. Is the original creator of this thread Fredbotton's model .ini file the one people are downloading for this? I really don't want Stagility mode mixed into the file.

Appreciate if anyone can help, cheers!

Please Log in or Create an account to join the conversation.

More
10 Apr 2018 18:50 #68602 by ursus69
Replied by ursus69 on topic Blade 200QX
Hi people!
I have a Blade 200QX flying with my devo10 (with stagility)and flies very well!!
I have a Taranis plus too, and I would fly my 200qx with the taranis...

Somebody have a 200qx taranis model?
I would appreciate your help!

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds
Powered by Kunena Forum